1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

phone bricked

Discussion in 'Android Tech Support' started by Shoaib, Sep 6, 2011.

  1. Shoaib
    Offline

    Shoaib New Member

    Joined:
    Sep 6, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi All

    My name is Shoaib

    I have Droid 2 Global

    i tried to charge my mobile with some chinese charger and when i insert jack my mobile goes dead then i tried to start it but every time it stucks on "M" logo i waited even more than 1 hour but no response then i pull out its memory card out and it starts normaly but with in 2 or 3 minutes it starts restarting then i pluged orignal charger and it worked 100 % ok but without memory card.

    with memory card it stucks on "M" logo with and without charger

    please help me

    Thanks in advance

    my email id is
    goldworthimpex@gmail.com