E-mail problem

Discussion in 'Android General Discussions' started by johng, May 19, 2010.

  1. johng

    johng New Member

    Joined:
    Dec 15, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    North Dakota
    Ratings:
    +0
    I am trying to set up my Mid-Continent (Midco) email account on the Droid. I can receive mail but not not send it. Midco tells me that I need to contact Verizon to find out what out going smtp and port they use and Verizon tells me that they don't support a mobile smtp anymore. Any suggestions.

    (.mac and g-mail seem to work fine, only problem is with the Midco account)

    Thanks
    John
     
  2. aminaked

    aminaked Silver Member

    Joined:
    Jan 10, 2010
    Messages:
    2,183
    Likes Received:
    0
    Trophy Points:
    101
    Location:
    California, USA
    Ratings:
    +0
    Stab in the dark: try smtp port 587
     
  3. johng

    johng New Member

    Joined:
    Dec 15, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    North Dakota
    Ratings:
    +0
    Tried that already no luck. I think I need to use another smtp rather then smtp.midco.net
     
  4. aminaked

    aminaked Silver Member

    Joined:
    Jan 10, 2010
    Messages:
    2,183
    Likes Received:
    0
    Trophy Points:
    101
    Location:
    California, USA
    Ratings:
    +0
    Oh, that sucks. Their smtp server doesn't allow authentication and blocks you if you aren't connecting from home? Personally, I think that's very crappy of them. What are you supposed to do if you travel? They need to get out of the dark ages. End rant.
     
  5. spectacular

    spectacular New Member

    Joined:
    May 19, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    North Dakota
    Ratings:
    +0
    johng, did you ever find a solution?
     
  6. johng

    johng New Member

    Joined:
    Dec 15, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    North Dakota
    Ratings:
    +0
    Not yet, tried the smtp settings from the .mac account, no luck there.
     
  7. spectacular

    spectacular New Member

    Joined:
    May 19, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    North Dakota
    Ratings:
    +0
    I emailed Midcontinent, sending a link to this thread and this is their reply:

    "Thank you for contacting Midcontinent Communications.

    As stated previously, we don't have an authenticated SMTP server available for an outside Midcontinent connection. You can connect to email through any connection Midcontinent services.

    Connections from outside the Midcontinent connection will not allow SMTP traffic at this time. Since you are utilizing a connection from another network when checking email with a smartphone (other than a Blackberry, they have their own server they use and have not dropped the SMTP servers like most cell providers have) then you would want to find a solution through the network provider you are making that connection with.

    We do have WebMail available for customers who would like to send messages while away from home at mail.midco.net.

    We value you as a customer and appreciate your business. If you need further assistance, please reply to this email. You can also visit one of our Customer Service Centers or call 1-800-888-1300.


    Midcontinent Communications"​

    I guess it doesn't look good for us Midcontinent users. :-(
     
  8. johng

    johng New Member

    Joined:
    Dec 15, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    North Dakota
    Ratings:
    +0
    Guess I'll be relying on g-mail and the .mac accounts for now. Thanks all.
     
  9. JamisonM

    JamisonM New Member

    Joined:
    Jul 26, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Midco Account

    I figured out how to get my Midco account to work on my Droid X. The smtp server setting needs to be smtpa.midco.net, port 25 and do not check the use secure connection check box.

    Hope this helps.
     
  10. takeshi

    takeshi Silver Member

    Joined:
    Nov 29, 2009
    Messages:
    4,581
    Likes Received:
    0
    Trophy Points:
    151
    Ratings:
    +0
    It probably doesn't work outside their network (i.e. not on WiFi while connected to the internet via Midco) though. That's generally the issue with SMTP servers that don't support any form of authentication as an anti=spam measure.
     
  11. BrazenHed

    BrazenHed New Member

    Joined:
    Aug 15, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    smtpa.midco.net works.

    I just wanted to throw in my two cents that I was able to send email from outside of midco's network after changing the server to smtpa.midco.net.

    This must be a recent change. I had to help my dad out this weekend. He's not sure how long it hasn't been sending properly but I'm fairly sure that it was working with smtp.midco.net from an outside network earlier this year.

    ...And don't get me started on how much I hate Midco. Worst... ISP... EV-AR!

    A few years ago, they actually tried to tell me that it was technically impossible to setup forwarding on their email accounts. When I called them on their BS and forced them to let me talk to a manager, they finally admitted that it was their policy to not forward email accounts due to "security settings" to protect people from viruses.

    Yeah... Because forwarding from your crappy email server to my trusted Exchange server, (which takes the email off of your servers AFTER it's gone through your filters) is a security risk... Whatever, idiots.

    Anyway, for that situation, POPCon (Big thumbs up for that, BTW) provided me with the workaround that I needed.

    But I digress... Bottom line, Midco sucks worse than any ISP I've ever come across, but if you need to relay outgoing mail with your own VALID email account from an outside network, smtpa.midco.net will let you do what you need to do (for now).
     
  12. Zzz73

    Zzz73 New Member

    Joined:
    Sep 25, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    This cleared it right up for me. Many thanks!
     
  13. bonfire817

    bonfire817 New Member

    Joined:
    May 3, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thank you thank you!!

    I joined just to say THANK YOU (but I am already finding interesting stuff, so glad I did). I have been banging my head into the desk for 3 hours here trying to get my midco mail to work, and finally found this thread. YAY! It works! I also had to uncheck the log in each time to get it to work. Thanks so much!!
     
Search tags for this page
mail midco.net
,
mail.midco.net
,
midco email
,

midco email settings

,

midco.net email settings

,
midco.net email setup
,
midco.net mail settings
,
midconetwork email settings
,
midconetwork.com email settings
,

midcontinent email