Stock Calendar for Sapphire

Discussion in 'cvpcs' started by Masx, Aug 21, 2010.

  1. Masx
    Offline

    Masx New Member

    Joined:
    Aug 6, 2010
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    0
    Hey all just curious as to what version Sapphire uses? I recently just installed Sapphire to try it out replacing BBv0.4. When I was setting up my Pure Grid Calendar I was selecting which Calendar to use and selected the Stock Google 2.2 and it told me I didn't have that installed. So I selected the 1.5-2.1 Stock Calendar option and it worked fine. When I was using BB it worked fine when I selected 2.2 so I was kind of baffled when I couldn't for Sapphire.

    So by this I assume it's not using the updated version? Not a big deal but just curious as to what the difference is or if there are any.

    Thanks!
  2. brochaos
    Offline

    brochaos New Member

    Joined:
    Dec 23, 2009
    Messages:
    781
    Likes Received:
    0
    Trophy Points:
    0
    i use pure calendar, and was curious about this too...
  3. hakaida
    Offline

    hakaida New Member

    Joined:
    Jun 29, 2010
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    0
    I use agenda widget and it uses the 2.2+ api.
  4. grimloktt
    Offline

    grimloktt New Member

    Joined:
    Apr 3, 2010
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    0
    It must be using something older than 2.2. It won't work with 2.2. So, I just use 2.1 with no problems...
  5. Masx
    Offline

    Masx New Member

    Joined:
    Aug 6, 2010
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    0
    I ended just deleting the calendar.apk that was included in the Sapphire and replaced it with the one from the FRG22 and it works fine now when selecting 2.2
  6. kruizin
    Offline

    kruizin Addicted to ROM Premium Member

    Joined:
    May 6, 2010
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    0
    Or, just hit your stock calendar icon, then hit agenda from the menu button. Works really well for me anyways...
  7. wingdo
    Offline

    wingdo New Member

    Joined:
    Feb 17, 2010
    Messages:
    1,035
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Chicago
    Sapphire is built from ASOP (google) source. Calendar.apk and CorpCal.apk are both part of the ASOP build. Therefore .... the version supplied is the version Google had in source on the day sapphire 1.0.0 was built which was August 4th.

    I have no issues with using the 2.2+ calendar with agenda widgets.
  8. grimloktt
    Offline

    grimloktt New Member

    Joined:
    Apr 3, 2010
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    0
    Where'd you get it?
  9. Masx
    Offline

    Masx New Member

    Joined:
    Aug 6, 2010
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    0
    Peter Alfonso

    I downloaded the FRG22 deodexed and took the CalendarGoogle.apk from the system/app and replaced the Calendar.apk from the Sapphire one.
  10. grimloktt
    Offline

    grimloktt New Member

    Joined:
    Apr 3, 2010
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    0
    Do you put the caledargoogle.apk on your phone and then install it or do you just put it in a certain folder...or both?
  11. grimloktt
    Offline

    grimloktt New Member

    Joined:
    Apr 3, 2010
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    0
    I tried to install it but got "application not installed."
  12. jayman350
    Offline

    jayman350 New Member

    Joined:
    Jan 8, 2010
    Messages:
    845
    Likes Received:
    18
    Trophy Points:
    0
    Location:
    Lowell, Ma
    I've been having issues with Pure Calendar widget. Can't get the 1.5-2.1 or the 2.2+ options to work. I'm downloading the file Masx suggested to give it a shot. It has really been bugging me b/c I was using the PC widget a lot to keep up with Gtasks and my calendar all in one.

    hopefully this will fix that problem.
  13. grimloktt
    Offline

    grimloktt New Member

    Joined:
    Apr 3, 2010
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    0
    Well, the file he suggested failed to install for me. I did, however, download the 2.2 calendar modification someone posted on the forum. It's an updated stock 2.2. calendar where you can change the beginning of the week, etc. After successful installation, I tried to change Pure Calendar to 2.2 versus 1.5-2.1 with no luck. Pure Calendar still works under 1.5-2.1 setting. When I go to the calendar itself on my phone and check settings, it says 2.2.

    Bottom Line: It's not affecting anything, and I don't know what I'm missing if anything. I'm not worrying about it for right now.
  14. Rhino413
    Offline

    Rhino413 New Member

    Joined:
    Jun 16, 2010
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    0
    Sapphire 1.0 comes with calender 2.2 already in it from the get go
    the issue is with the calender widgets not seeing it. I don't know why but i'm having the same issue as well with pure calender. but when i use root explorer and go to system/apps/calender.apk and select view then open the meta file it shows it as 2.2 on pure messenger and pure calender just select the 2.2 option and it gives a warning about it not being there and that it wont work just select ignore and it works fine. or at least it did for me
  15. Masx
    Offline

    Masx New Member

    Joined:
    Aug 6, 2010
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    0
    The way I installed it was making a copy of the original Sapphire install zip and deleted the Calendar inside of that replacing it with the 2.2 Calendar apk from that link I posted. I believe I had to rename it from GoogleCalendar to just Calendar.

    Reason I did this was because I reloaded a backup of BB to see if something was wrong and I also modified a few more things such as transparent notification slide down and changed the boot animation. So I reinstalled using the modified zip.

    I tried doing that in my widget but it gives me the error and doesn't change to the calendar. So the only fix in the widget was to use the 1.5-2.1 Calendar selection. But after doing what I said above it allowed me to select 2.2 no problem and all is working well. As for any big difference between the 1.5-2.1 selection vs 2.2 I have no idea. But it sure was annoying enough for me to try and fix it :)
    Last edited: Aug 26, 2010
  16. jayman350
    Offline

    jayman350 New Member

    Joined:
    Jan 8, 2010
    Messages:
    845
    Likes Received:
    18
    Trophy Points:
    0
    Location:
    Lowell, Ma
    I was able to place the calendargoogle file into /system/data.
    I renamed the original calendar instead of deleting it.
    Instead of installing the apk you simply copy and past it into /system/data.
    Check the permissions on the original calendar and make them the same for the new file you just added.
    reboot and give it a whirl.

    It worked for me, except that there is now a black bar that blocks most of the first line of the calendar. The widget will now recognize the 2.2 calendar with no ill effects aside from the black bar.
  17. Masx
    Offline

    Masx New Member

    Joined:
    Aug 6, 2010
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    0
    Cool, glad you got it working but I have no black bar and that would surely annoy me more then the 2.1 selection lol.
  18. Rhino413
    Offline

    Rhino413 New Member

    Joined:
    Jun 16, 2010
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    0
    thats a good question other than the pride of saying its 2.2 what does
    it give you over 2.1. and if the apk in sapphire is saying 2.2 what is the big deal if the dumb widget is selected to 2.1 as long as i'm not missing out on some functionality then this is just a quest for pride and name sake
  19. Rhino413
    Offline

    Rhino413 New Member

    Joined:
    Jun 16, 2010
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    0
    and other than the warning that states the selected calender application to launch on widget tap, doesn't seem to be installed on your device. Showing up when ever i go into the widget settings. the app and calender seem to work just fine when selected to 2.2