Questions about Leak/NonLeak/OTA for RubiX look here

Discussion in 'Drod2169 - X' started by Droid74, Dec 13, 2010.

  1. Droid74
    Offline

    Droid74 New Member

    Joined:
    Sep 17, 2010
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    0
    If you are on the .320 Leak from TBH and want to get to the .340 OTA follow the instructions here:

    TBH Patches: 2.3.340-System, Baseband, 2.3.340-Kernel, Bootloader

    If you are on the official .340 OTA no worries you are good.

    Now, this is really important. Once you are on the official .340 OTA or used the above info to go from the .320 Leak to the .340 OTA you can use the "LEAKED version of Rubix Focused 1.9" then just use this patch after you install Rubix Focused 1.9:

    http://www.droidforums.net/forum/drod2169-x/104626-patch-focused-1-9-0-update-2-3-340-a.html

    Once you have done that you are good to go and can use ANY Theme for RubiX Focused 1.9!!! Woot!!
  2. bwalker12
    Offline

    bwalker12 New Member

    Joined:
    Nov 3, 2010
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    So I restored to stock, updated to .340, and installed Rubix. System still says2.3.15. This patch will make it say .340?
  3. antilogic
    Offline

    antilogic New Member

    Joined:
    Oct 1, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Sounds like a pain. Hopefully the next release will include the OTA updates, or do we need to go this leaked + patch route?
  4. sephtin
    Offline

    sephtin New Member

    Joined:
    Aug 20, 2010
    Messages:
    1,807
    Likes Received:
    0
    Trophy Points:
    0
    The patch corrects the version line in build.prop to display 2.3.340, yes.
  5. sephtin
    Offline

    sephtin New Member

    Joined:
    Aug 20, 2010
    Messages:
    1,807
    Likes Received:
    0
    Trophy Points:
    0
    Focused will not include updating to 2.3.3xx... you have to do it yourself.
  6. bwalker12
    Offline

    bwalker12 New Member

    Joined:
    Nov 3, 2010
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Installed patch and it works flawlessly. Thanks guys
  7. OnMy2ndGP
    Offline

    OnMy2ndGP New Member

    Joined:
    Sep 27, 2010
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    0
    Success! I took the OTA plunge to .34 the other day. Would not have if I hadn't seen this thread. rubiX 1.9.0 for president!!! Ooops, it's only software....LOL! But the best software I've used on my DX.
  8. drod2169
    Offline

    drod2169 Premium Member Premium Member Developer

    Joined:
    Apr 12, 2010
    Messages:
    677
    Likes Received:
    0
    Trophy Points:
    0
    If i'm understanding right.. you're asking if you'll need to install another patch to stay on .340 or if you'll have to load a .320 or 2.3.15 version and install the .340 patch? If that's the question, then no, you won't. Every release from here on will be based off 2.3.340 since it is the new OTA and is official.

    If you're asking if I'll update it for you.. sure if you bring me your DX, I'll update it to 2.3.340 :) but no, not through rubiX Focused. Way too much of a risk to break something on my part, and its just not worth it anyways. Taking it officially or through TBH works better than I could provide.
  9. chefb
    Offline

    chefb Member

    Joined:
    Aug 30, 2010
    Messages:
    981
    Likes Received:
    5
    Trophy Points:
    18
    I need to update, my computer is broke,and my original update I apparently saved through rom manager and never saved is there a link to the tbh leak, I'm on rubix 1.8.9 system version 2.3.20
  10. thelionelking
    Offline

    thelionelking New Member

    Joined:
    Jan 29, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    Okay, please confirm if this is the proper route from Focused 1.9 on 2.3.15 to Focused 1.9 on 2.3.340?

    1. SBF with the latest 2.3.32
    2. Pull 2.3.340 OTA update and install
    3. Root with Z4Root
    4. Flash Rubix Focused 1.9 for 2.3.320/2.3.340 only
    5. Flash PATCH — Focused 1.9.0 update to 2.3.340
    6. Enjoy

    Please advise because I am on the verge of doing so...
  11. meshdub
    Offline

    meshdub New Member

    Joined:
    Nov 3, 2010
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    0
    Step 1 is SBF 2.3.15, not .32!
  12. thelionelking
    Offline

    thelionelking New Member

    Joined:
    Jan 29, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    Oh wow that would've been quite a mistake huh? So SBF'ing back to 2.3.15 will allow me to pull the OTA and update to 2.3.340?

    Are the rest of the steps correct?
  13. meshdub
    Offline

    meshdub New Member

    Joined:
    Nov 3, 2010
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    0
    yeah, the rest is correct. I can confirm, because that's exactly what I did yesterday night =)

    In step 3 you'll also have to get Bootstrap, but I assumed you know that already.
  14. thelionelking
    Offline

    thelionelking New Member

    Joined:
    Jan 29, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    Why yes of course! Thanks very much!
  15. sephtin
    Offline

    sephtin New Member

    Joined:
    Aug 20, 2010
    Messages:
    1,807
    Likes Received:
    0
    Trophy Points:
    0
    Looks correct to me. GL!
    Let us know if you have any troubles!
  16. OnMy2ndGP
    Offline

    OnMy2ndGP New Member

    Joined:
    Sep 27, 2010
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    0
    Same here. Working great on this end too.

    rubiX 1.9.0 (non-leak) DX on the v4 Juice via DF app
  17. jfalco
    Offline

    jfalco New Member

    Joined:
    Dec 17, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Worked great. Hard key backlight not working anymore though, unless I missed a setting somewhere.
    --edit Working now, strange

    Sent from my DROIDX using DroidForums App