Installed Liberty ROM on my Droid 2, now I think it's bricked

Discussion in 'Droid 2 Tech Issues' started by Klaus, May 26, 2011.

  1. Klaus
    Offline

    Klaus New Member

    Joined:
    May 25, 2011
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    An hour ago I installed the Liberty ROM found in this thread (http://www.droidforums.net/forum/liberty-rom-d2/137381-droid2-liberty-rom-v-2-0-a.html) on my Droid 2.

    I followed all the instructions properly, and even made a backup using clockwork, wiped data and cache, etc etc. And got the success message after I clicked on the LIBERTY .zip file and installing it.

    Now the only thing my phone does is showing the LIBERTY boot screen every time I press the power button and then after a few seconds the screen goes completely black, without even showing the clockwork restore options.

    I'm also afraid that the stock recovery options (Holding the power button and the 'x') won't work either.

    After trying everything, I downloaded the .sbf file and the RSD lite, just to discover that my computer can't (obviously) recognise the device, therefore not allowing me to flash the .sbf.

    So yeah, I think I'm left with my bricked device now. What do you guys suggest?

    Thanks, Andrew.

    EDIT: So I just figured out that you enter the stock recovery by holding the power and arrow up keys on the Droid 2...
    Last edited: May 26, 2011
  2. pressguy27
    Offline

    pressguy27 Member

    Joined:
    Jan 21, 2011
    Messages:
    181
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    michigan
    Ratings:
    +0
    If you can get into the stock recovery hit the magnifying glass when you see the android guy with exclamation point, then clear data and cache and see if that help

    Sent From The Zombie Who Has My DROID 2
  3. Klaus
    Offline

    Klaus New Member

    Joined:
    May 25, 2011
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Sorry. I was wrong. I got into the bootloader, my bad. It says battery OK and Transfer mode: USB.