1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

ICS leak kernels - no deep sleep?

Discussion in 'Droid 4 ROMS' started by olegfusion, Jul 17, 2012.

  1. olegfusion
    Offline

    olegfusion New Member

    Joined:
    Jun 30, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    [FIXED]ICS leak kernels - no deep sleep?

    Hi, guys. I'm new enough with droid 4. But the one of this thing I found - I installed 215 leak ics, now I'm using it, but looks like it is not moving CPU to deep sleep state at the night.

    Was anybody noticed about that thing in the previous ICS leak? I tried only kernel from 215 leak and here no deep sleep. At night it's working on 300MHz state.

    If anybody has experience regarding that at previous leaks, let me know.
    Last edited: Jul 17, 2012
  2. kenji91
    Offline

    kenji91 New Member

    Joined:
    May 13, 2012
    Messages:
    458
    Likes Received:
    5
    Trophy Points:
    0
    I can't really speak on MotoICS215's behalf, but I did install the ICS215 kernel and am running CM9 on that. And I've reached deep sleep.

    http://sphotos-a.xx.fbcdn.net/hphotos-snc6/181389_10151053199338324_628845842_n.jpg
  3. kenji91
    Offline

    kenji91 New Member

    Joined:
    May 13, 2012
    Messages:
    458
    Likes Received:
    5
    Trophy Points:
    0
    Also, this build.prop tweak may or may not help achieve deep sleep.

    ro.ril.disable.power.collapse=1

    Edit: I've been using 1 as the value, but now that I look at it... it makes more sense to be 0. Assuming 0 = no, you DON'T want to disable power collapse (deep sleep?).
  4. olegfusion
    Offline

    olegfusion New Member

    Joined:
    Jun 30, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    can't open the picture, sorry

    I see now that build.prop already has deep sleep support { ro.mot.deep.sleep.supported=true }
    but I'll try your fix.
  5. olegfusion
    Offline

    olegfusion New Member

    Joined:
    Jun 30, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    ok. Found the problem. Wifi doesn't make deep sleep.
  6. kenji91
    Offline

    kenji91 New Member

    Joined:
    May 13, 2012
    Messages:
    458
    Likes Received:
    5
    Trophy Points:
    0
    The kernel info in my picture shows that it hasn't been changed since July 11th.
  7. olegfusion
    Offline

    olegfusion New Member

    Joined:
    Jun 30, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    very sorry, I had DNS issue. Yes, I see now, but you're on 4g network. I found that I have deep sleep without wifi enabled, but no deep sleep with wifi is.
    Do you know the library of wifi module?

    Kernel wakelock is called "rx_wake" drains the battery and prevent deep sleep.
    Last edited: Jul 17, 2012
  8. kenji91
    Offline

    kenji91 New Member

    Joined:
    May 13, 2012
    Messages:
    458
    Likes Received:
    5
    Trophy Points:
    0

    I have no way of not being on a 4G network unless I have poor reception. In ICS/CM9, I don't have the option to toggle 4G off.
  9. olegfusion
    Offline

    olegfusion New Member

    Joined:
    Jun 30, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    ok, fixed this trouble. replaced original wpa_cli and wpa_supplicant from cm9 and wifi allows deep sleep now.
  10. olegfusion
    Offline

    olegfusion New Member

    Joined:
    Jun 30, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    update
    Seems like it was only one lucky boot. No more connection to my router though wpa

    update2.
    got rid of that problem. I unhided the SSID of my wifi connection and Deep sleep is fine now.
    Last edited: Jul 17, 2012
Search tags for this page
android cannot deep sleep
,
android deep sleep not.supported
,
deepsleep kernel
,
enable deep sleep cm9
,
ics sleep wifi
,
ro.ril.disable.power.collapse=1
,

rx wake

,
rx wake android
,
rx wake kernel wake lock
,
rx wake kernel wakelock
,

rx wake wakelock

,
rx wake wakelock kindle
,
wakelock rx wake
,
wakelock rx wake razr xt912
,
wlan rx wakelock