Droid 1 and Exchange 2010 password fix

Discussion in 'Android Support' started by badog, Sep 26, 2010.

  1. badog

    badog Member

    Joined:
    Aug 15, 2010
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Lost in Iowa...
    Ratings:
    +0
    Ok, so there's lots of different threads floating around on how to fix Exchange email and being forced to enter a password or pin everytime you wake up the phone. So far this is the only solution I've found that doesn't require buying another app, installing another email app or rooting the phone.

    This only works for Droid 1 and Exchange 2010...I haven't tested 2007 so it may or may not work on 2007

    On Exchange 2010 create a new active sync policy (editing an existing policy won't work) that has the following settings:
    - Allow non-provisioned phones = NOT selected
    - Password required = NOT selected.
    - Add the policy to your exchange account
    - Give the policy 5 to 10 minutes to propagate out.

    - Delete your Exchange account on your phone
    - On your phone, go into settings | locations & security | select device administrators = remove/deactivate your email account (if it's still there after deleting your account)
    - On your phone, go into settings | locations & security | set up screen lock = select "none". You'll have to enter your password once for it to disable the password.
    - I suggest rebooting the phone at this point to make sure the password policy and email account is gone.

    - Remove all phones from OWA client (webmail). (there's an entry for every time you added an exchange account to the phone, so remove them all).
    - Create a new exchange account on your phone by going into email app
    - Accept the security policy and activate (it won't ask for a password)

    I've done this on both rooted and non-rooted phones and every phone no longer requires a password. I did run into a few that I had to repeat the process a few times for it to take, but I think that was just a timing issue with our exchange servers (we have over 60,000 users so changes takes a bit to be seen).

    I suggest not making this a default active sync policy, only use it for trusted people with droid 1's.

    Good luck.
     
  2. Backnblack

    Backnblack Premium Member
    Premium Member

    Joined:
    Nov 18, 2009
    Messages:
    11,261
    Likes Received:
    24
    Trophy Points:
    453
    Ratings:
    +24
    Current Phone Model:
    iPhone 7+ 256gb
    I use Touchdown and have zero problems with 2010....
     
  3. badog

    badog Member

    Joined:
    Aug 15, 2010
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Lost in Iowa...
    Ratings:
    +0
    That and improved email seem to work, I'm just giving another solution that doesn't require spending money on another app or rooting :)
     
Search tags for this page
android passcode wont show up exchange 2010
,
android v4.1.2 fix exchange
,
changing exchange password on droid incredible 2
,
droid exchange requiring password
,
droid remove exchange account password
,
exchange 2010 active sync password policy for android
,

exchange 2010 activesync pin

,
exchange 2010 android password
,
exchange 2010 requires android to have password
,
exchange2010 android password