2 Vz Apps missing from AOKP JB 4.2.2

Discussion in 'Droid RAZR Hacks' started by David Reed, Oct 29, 2013.

  1. David Reed
    Offline

    David Reed New Member

    Joined:
    Oct 28, 2010
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Springfield, Missouri
    I have only recently rooted my Razr XT912. I placed the Stock_Droid_Razr_JB_Manual_Update_Windows Utility on my PC, ensured I had USB debugging rigged properly, then ran the Utility to wipe the RAZR and install Stock JB 4.1.2, then ran the Utility again to Root it, and then to install Safestrap. All went well.dancedroid


    I had all the backups necessary to restore, but it was not necessary to do so and all is well on the "Stock" ROM Boot. I copied "aokp_spyder_jb-mr1_milestone-2.zip" and "gapps-jb-20130301-signed.zip" to the Root of SDCard0. I then rebooted into Recovery mode. That also went fine. I configured ROM-Slot2 renaming it "AOKP". I then Activated that slot, and installed "aokp_spyder_jb-mr1_milestone-2.zip" and "gapps-jb-20130301-signed.zip" to the ROM-Slot2-AOKP:hail:. I rebooted, and all is well there, also.:icon_ lala:


    Almost. There are two apps in the Vz ROM, prior to and including JB 4.1.2 that I utilize frequently, and am very content with that DO NOT exist in the AOKP ROM. Specifically, two options in the Vz Mobile Hotspot controls in Settings, and the complete absence of Vz Visual VoiceMail.


    The ability to configure the name, password, and activate the Hotspot still exist in Settings, however there are two security features that are not, and that is my greater concern. I did install the kr.core.technology.wifi.hotspot v.1.30 from Google Play Store and looked at two other similar apps to see if I could regain the security functionality, but alas, none offer the extra controls.


    Mobile HotSpot Issues:


    Specifically, the two additional options were to "Limit the number of allowed devices", ranging from two to eight. I have only one, so I used the setting of two. I "assume" setting to a greater number provisions resources I would rather conserve. The more important option to me, was the ability to enter the MAC address of allowed devices, to the exclusion of any device not included in the "Allowed Devices List".


    Visual VoiceMail Issues:


    Yes, I can still access Voicemail the old way, or use YouMail or Google Voice. I simply don't want to encumber myself with the configuration of the additional steps and options necessary to do so. I tried YouMail and find I feel awkward and somewhat disconnected from the root connection to Vz (definitely a love/hate relationship), and must assume Google Voice would be somewhat the same. I don't need transcribed text copies, umpteen greetings, or call-blocking, etc. I use the everycall.us "Call Control Pro" app for that.


    I like the simplicity of hitting one-button and seeing the list of all voicemails, heard and unheard, and the ability to save, forward and restore them all in the same menu.


    So, why am I bothering you with this? I will be posting this publicly on AOKP:hail:, droidforums.net & droidrzr.com, but understand that xda was instrumental in this project, unless I'm mistaken.


    I "assume" there is some reason these were not included, but not being a dev or programmer, wouldn't have a clue why.


    I am a 60 year :Dold tech geek, hearkening back to the days before mice and a GUI. From 1995-1998, was a certified Novell Advanced Admin (NOT a "paper" cert! I earned it with my arms elbow-deep in hardware:lifting:) PC builder/installer/troubleshooter and PC desktop OS (Win 1.x thru Win 3.? w/networking) and OS/2 (God save us from IBM, please!) support tech.


    I was also an Application Support Specialist, and Novell GroupWise 4.x & 5.x Admin w/5000+ users in the Clark County (Las Vegas), Nevada County Government. I had only my last two exams (the big ones) to pass to have earned my Engineer cert. I then left the big city, moved to the Midwest to prepare for the aftermath of Y2K.:happy2:


    I considered it not simply a potentially serious threat, but also a Golden opportunity to rebuild community control of our country from the trash heap of centralized control in D.C. There was not a more disappointed:icon_ cry: man in America by Jan 2nd, 2000 than I. So, I became an Independent Owner/Operator, driving my own 18-wheeler hauling freight. Successfully I might add, until the economy tanked in Q1 of 2009.


    That being said, I am able to grasp most of what I am learning about taking Root and modifying some, but not all of functions of the smartphone animal.


    So, I tried something that did not work, either because it won't, of because I have not done it properly. I rebooted into the Stock ROM, and located HotspotLauncher.apk .odex, as well as the Vvm.apk and .odex files. I then copied them to a new directory I can access from either boot mode. I rebooted in the AOKP:hail: mod, located the files, copied them once again, only this time to the /system/apps dir. From there I 2x-clicked the Hotspot app, which brought up the android installer, answered yes and it ATTEMPTED to install the app, but reported it as unsuccessful. I tried the same on the Vvm app, with the same failed result.


    So, is there a reason they CAN'T be installed, or am I simply doing it wrong?:unsure:


    I look forward to whatever response I get, even if I'm unable to do what I want, I will learn more and that is never a bad thing.:cool-b:


    Thank you for your contributions to the Android endeavors, past & future!! :hail: dancedroid
  2. lloydsw
    Offline

    lloydsw Member

    Joined:
    Jan 29, 2013
    Messages:
    138
    Likes Received:
    8
    Trophy Points:
    18
    Not germane to your problem, but my kids still talk about how much they liked OS/2!
Search tags for this page

aokp app

,

aopk 4.2.2 wifi hotspot

,

springfield android hack