Safestrap crashes on open


New Member
Jan 27, 2012
Reaction score
I'm relatively new to Droid 3 flashing, my D2 has CyanogenMod 7 successfully installed, but the D3 is a whole other story.

I had Rom Manager and Droid 3 Bootstrap both installed from the market after having been rooted for a while. Come to find Hashcode has ICS and I decide to switch to Safestrap. Apparently not an easy process for me.

I uninstalled Droid 3 Recovery Bootstrap, Uninstalled ROM Manager, these instructions by guidot, then tried to install Safestrap from here.

It force closed on open.

Superuser has permissions for it and all other root things work fine.

After many re-installing it many time to no avail and rebooting as many times, I decided to restore to factory settings.

I then used Pete's One click to re-root. The standard process didn't work(couldn't push su or superuser of busybox), so I did the temp root and then adb'd the files over. Now I have root again, permissions work, terminal emulator accepts su, root explorer, etc.

Then I re-install Safestrap from Hashcode. Same problem, force close. then I find a 1.08c variant on XDA, safe thing; 1.08d, same thing.

So basically in a day I managed to make no progress, jump through 10 hoops, and wound up back where I started but without my apps, and without my launcher.

I could easily make my phone exactly like it was a day ago, but after all this I really just want Safestrap to work so I can flash.

I've Google searched, read posts of problems, and tried to figure this out a ton already, I'm just at the end of ideas and direction.

Any help/advice would be greatly appreciated.