Micro SD cards for HD/MAXX HD | Class 10 32GB vs 64GB

I have a 64 gig sandisk in my maxx g1, and I used the same card in my maxx HD when I had it. It worked just fine..:eek::confused:
Updated OP with some more info.

Final conclusion, 64GB cards will just not work...

Sent from my DROID RAZR HD using Xparent Cyan Tapatalk 2
I've been using a Sandisk mobile ultra 64gb class 10 in my Razr HD since SS3 came out w/o any issues. I was using my Samsung 32gb class 10 from my OG Razr prior to the 64gb also w/o issue on the Razr HD, I did have issues at times on my OG Razr with writing to both internal & external storage, & had the SD card pop up as blank a couple of times(corrupted partition table).

Most if not all of the time that I had the 64gb SD card in has been on 4.1. I mainly just use the SD card for storing music, pictures/videos, backups(both ROMs & user apps/data/etc). I copied all the old data from my 32gb to the 64gb SD card using root browser(romtoolbox) with 64gb in the SD card slot & the 32gb in a USB adapter in one the docks USB ports. I've had no issues reading/writing using romtoolbox(all other aspects not just root browser), stock files browser, SS3 or any other apps with the 64gb SD.

It also shows up in storage manager as expected.

Sent from my DROID RAZR HD using Xparent Red Tapatalk 2
Thank you for your input, maybe being on 4.1 will make the card usable and compatible. Maybe I'll flash the leak when I have time to try this out.

Have you tried using the "Manage Internal Storage" function to move media over that way? Back the card up and try it out and let me know if it moves large amount of data over with no issues.

This is interesting...
Also, just got my Class 10 32GB card and the first thing I tried was using storage manager to move movies over and it worked just fine.

I hope Jelly Bean likes the 64GB card cause that would be awesome.

Sent from my DROID RAZR HD
Well at least you know its the gigs not the class... that's good.

Sent from my DROID RAZR HD using Xparent Cyan Tapatalk 2
Well at least you know its the gigs not the class... that's good.

Sent from my DROID RAZR HD using Xparent Cyan Tapatalk 2

I think it's the way the 64 is formatted, it's formatted differently than others that apparently Android can't reinforce lol

Sent from my DROID RAZR HD
Neither of the 4.1 ROMs I currently have installed on mine have the file transfer options in storage manager, I'd think that it would work since everything else has. On my OG Razr I'd had issues with it at the times other things were also having issues other wise it also worked. I remember on the GB build that came on the OG Razr 95% of the time I tried to use the camera it wouldn't save to my old 8gb class 4 SD card and at some point the internal storage .

I've heard of peole having issues with SD cards that were formated on another device & then working fine after formatting them with the device they're in.

Sent from my DROID RAZR HD using Xparent Red Tapatalk 2
Galaxy S3... copied a couple gigs of music to my sd (16gb of the model we've been discussing), stuck the sd card back in, voila... half of it's corrupted and in the Lost.DIR folder. Whatever... I'm a little pissed right now, lol...

Maybe it's coincidence, but I've had Android for years, and literally never had these types of problems until I started using these Ultra Sandisk sd's.

I unmounted in the settings, ejected on my computer, remounted into phone and rebooted. Man I'm frustrated... I have to be up in 3 hours to catch a flight and wanted to listen to my music in flight.

Not only did it screw up all the music, my TB folder, "graphics" folder (with hundreds of icons), and a couple other smaller / less important directories... all gone. It also screwed up a few subdirectories I had synced with Dropsync - so what happens? Dropsync starts deleting them from my Dropbox, of course. Not a huge deal as I can restore in Dropbox, but still.

Dang dude, that sucks... maybe it is the ultra series... that's a bummer, I'll have to keep an eye on mine, maybe the S3 just doesn't like them, so far my SanDisk Ultra 32GB Class 10 is working great in my HD.
Ok, so adding more info here:

The SDXC (not SDHC) cards, which is what the 64GB card is (the 32GB and smaller are SDHC) uses a default file system called exFAT instead of FAT32. exFAT (extended file allocation table) is file system owned by Microsoft, such as NTFS. Android is currently not licensed for it, or somthing along those lines, I don't know or can't find the exact details - but in order to use a technology, you have to license it from its owner. Well that seems to be changing as according to this article MS is doing that with Sharp in Japan, who is the largest mobile phone manufacturer in Japan: Microsoft Signs up Sharp to License ExFAT File System for Android Smartphones | PCWorld

While FAT32 supports up to 2TB of space, the SDHC format for micro SD cards is 32GB, so anything larger has to be in the SDXC format which are formatted in the exFAT format. Now, get a load of this, ready?

SDXC supports up to 2TB! Imagine having a microSD card with 2TB of space! WOW!

Source: Secure Digital - Wikipedia, the free encyclopedia

In relation to Android, read this interesting article here: Tuxera Drives exFAT and SDXC Adoption on Mobile Devices | Tuxera
Yeah, I'm wondering if it's related to the SanDisk products period. When I try to return the SanDisk 32GB Class 4 card that just does not work in my OG RAZR, I'm going to get the cheap MicroCenter version instead. They have a CLass 10 32gb card for like $24 so I"ll try that over a SanDisk.

It will be definitely a great thing if Jelly Bean supports the 64GB cards (and bigger!) if they fix SDXC support and make them 100%. I'd assume Motorola would want to do that prior to releasing JB for OTA updates via Verizon.