Google Nav "Searching for GPS" Droid X

btmitc

New Member
Joined
Jun 1, 2011
Messages
2
Reaction score
0
I have searched and searched for info about this but I haven't been able to find the answer anywhere. For the past 3-4 month, when I attempt to use the turn by turn feature with my Droid X, its always stuck at a "searching for gps" error message. I have tried Hard Reset, downloading various GPS Fix apps but still no luck. Has anyone been able to fix this issue on their phone?
 
Thanks for the suggestions guys! I tried GPS Fix app and still no luck. Eventually called tech support, they walked me through troubleshooting, and after about 30 min, did a warranty exchange. Issue fixed for now, maybe it was a hardware issue. My original phone was one of the first batches of Droid X, got it the weekend it came out.
 
Had this problem for months and finally solved it the other day.

The GPS antenna in these things is uber sensitive. I am using a BH6X battery with the stock case. All I had to do was remove the battery cover and satellites starting popping up like wildflowers in GPS status. Put the stock battery back in and no problems at all with the case on.
 
Back
Top