GPS Problems


Nov 5, 2010
Reaction score
Is anyone else having recent problems with GPS?

I have a Droid X. Updated to the latest OS 2.2.1

GPS has worked great for months. But over the last week or two my navigation application doesn't seem to be able to get a lock. The Nav app just sits there saying "Searching for GPS". The app seems to be able to locate my general location, and generates a route from that general location, but it never goes into Navigation mode, just sits there saying "Searching for GPS". No better than the Google Maps app showing me a route.

Essentially I can't use the Nav app anymore, and other GPS apps take a LONG time to get a fix.

Any ideas out there?

My assumption is that you've rebooted and/or pulled the battery by now.

Doesn't sound like you're rooted or running a rom, but it can't hurt to ask.

I've noticed sometimes that the satellite "network" sometimes is patchy or just down. Not for a s long as you are talking.

Did you check your gps settings?

"what evrrrrr"

Yes, it is rooted. No, hadn't tried the battery idea at the time of my post.

Actually, after doing a little more reading on the subject I saw a post regarding removing the battery. Tried it a little while ago and it seems to have done the trick.

Any ideas as to why I would have to remove the battery to get my GPS functioning?


Sent from my DROIDX using DroidForums App
Ever restarted your computer cause its locked up? Even though its not exactly the same, its basically the same idea. For some reason or another the operation of said program isn't right, so a restart is in order.

Glad it helped.

"what evrrrrr"
I understand restarting. But seldom do I need to UNPLUG my computer from the wall in order to get things fixed.

I restarted the phone MANY times. Just haven't taken the battery out recently.

Anyway, that's all I was wondering about.

Thanks for the replies.

Go into maps and clear cache settings and reboot. Should work after that. Had the same issue

Sorry. Didn't see the issue was resolved. My bad

detoXatappin on my X