Why won't Skype work?

Discussion in 'Android Tech Support' started by tunaman, Jan 1, 2011.

  1. tunaman
    Offline

    tunaman New Member

    Joined:
    Jan 1, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Hi all!

    I'm a long-time IT guy who is new to Android (just got a VM Intercept for Christmas). I'm having an issue with Skype: I can log in and see all my contacts, but when I click on one to call them, I instantly get a "call ended" screen. If I try to call again, I get a message that says something like "2 calls in progress; you must end one to start another". I can't find any way to end the rogue call, so I use Advanced Task Manager to exit Skype and restart the app.

    Any suggestions? I've googled the heck outta this, but my Google-Fu has failed me.

    AFAIK, this is 2.1 on a VM Intercept, with the latest version of Skype installed from the Market. I've verified that my Wi-Fi connection is working properly with the phone.

    Ideas? Thanks in advance!
  2. furbearingmammal
    Offline

    furbearingmammal DF Super Moderator

    Joined:
    Jun 16, 2010
    Messages:
    10,354
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    So far north in NY I smell maple syrup when the wi
  3. tunaman
    Offline

    tunaman New Member

    Joined:
    Jan 1, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    1.0.0.659 - it's the latest one in the Android Market.

    As mentioned, Virgin Mobile.

    Thanks! :)
  4. furbearingmammal
    Offline

    furbearingmammal DF Super Moderator

    Joined:
    Jun 16, 2010
    Messages:
    10,354
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    So far north in NY I smell maple syrup when the wi
    Actually, you hadn't mentioned it. That's why I asked. :)

    I mean, are you using the WiFi-only or the 3G-enabled one?
  5. tunaman
    Offline

    tunaman New Member

    Joined:
    Jan 1, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Sorry. In the OP I said "got a VM Intercept for Christmas". I'm new to Android, but "VM" seems to be the standard abbreviation for Virgin Mobile at the handful of sites I've been to.

    I'm not sure I understand your second comment. Yes, it's a 3G phone, but Skype only seems to work via Wi-Fi. For troubleshooting purposes, I disabled Wi-Fi on the phone to try to force it to use 3G, but Skype kindly told me that it only works via Wi-Fi in the US.
  6. furbearingmammal
    Offline

    furbearingmammal DF Super Moderator

    Joined:
    Jun 16, 2010
    Messages:
    10,354
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    So far north in NY I smell maple syrup when the wi
    We're mostly a Verizon site. :) My apologies for not recognizing the abbreviation. Hopefully that won't slip by me again. :)

    Interesting. Last I checked there was a 3G version as well as WiFi Version. Of course, I'm on an Android 2.2 phone. Let me check to see if that's still the case. If not, there's a hacked app available here that DOES work over 3G, for most people, that I could point you at.
  7. furbearingmammal
    Offline

    furbearingmammal DF Super Moderator

    Joined:
    Jun 16, 2010
    Messages:
    10,354
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    So far north in NY I smell maple syrup when the wi
    I take it back. My Skype listing in the market says "Free* Skype-to-Skype calls over 3G or WiFi!"
  8. furbearingmammal
    Offline

    furbearingmammal DF Super Moderator

    Joined:
    Jun 16, 2010
    Messages:
    10,354
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    So far north in NY I smell maple syrup when the wi
    And now that I think about it, the Samsung phones have major issues with Skype. The Fascinate especially.
  9. tunaman
    Offline

    tunaman New Member

    Joined:
    Jan 1, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Progress? I found another thread that offered the following tip:

    1) Log out of Skype and disable Wi-Fi on the phone.

    2) Enable airplane mode, then wait a few seconds and re-enable Wi-Fi.

    3) Log back in to Skype.

    4) Calls mysteriously go through.

    Even after you take the phone out of airplane mode, calls continue to go through. I don't know why this is, but it seems to work... so far.
    Last edited: Jan 2, 2011
  10. furbearingmammal
    Offline

    furbearingmammal DF Super Moderator

    Joined:
    Jun 16, 2010
    Messages:
    10,354
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    So far north in NY I smell maple syrup when the wi
    Ah, that's actually a functional workaround. Samsung phones are tricky when it comes to Skype.

    The reason that method works is that, for whatever reason, Samsung phones try to access 3G unless it's not available, but can't, and error out like you saw. I don't have WiFi at home so I don't even think about enabling it 90% of the time, so...

    By turning on Airplane mode and then toggling WiFi you're forcing Skype to use WiFi because there's no 3G available. Clever. Pain in the butt, but clever. :) Thank you, kind sir, as I have been schooled today. ;)
Search tags for this page
android skype wont start
,
call failed skype android
,
skype app wont open android
,

skype call failed android

,
skype for android wont open
,
skype wont sign in android
,
skype wont work on android
,
skype wont work on my android
,

why won't skype work

,

why won't skype work on my android phone

,
why won't skype work on my phone
,
why wont skype work on my android phone