SetCPU issue

Discussion in 'Android Applications Discussions' started by jttak82, Jul 22, 2010.

  1. jttak82

    jttak82 New Member

    Joined:
    Jul 17, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I've been using setcpu for awhile and I'm loving it but I have one weird issue I can't seem to fix. I have a profile set when I'm charging my phone but no matter what I set the sliders to, the phone runs 200 above what I set at max and it stays there. Right now I have that profile set to 500 max and it runs at 700. My other profiles work fine without a hitch. I had it set on boot so I've tried rebooting but no dice. My friend suggested different kernels and roms but that doesn't work either...any thoughts?
     
  2. Skull One

    Skull One Member

    Joined:
    Mar 11, 2010
    Messages:
    759
    Likes Received:
    6
    Trophy Points:
    18
    Ratings:
    +6

    The Droid when plugged into an AC charger will default to a frequency of 500 Mhz or above depending on the the number of slots and frequencies provided. That is not a failure of the kernel nor of SetCPU. It is a built in feature of the Android OS for the Motorola Droid. At present I know of no way to override this behavior.
     
  3. jttak82

    jttak82 New Member

    Joined:
    Jul 17, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thank you very much! At least now I know there's nothing wrong with the phone


    Sent from my droid using Tapatalk
     
  4. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,959
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    I have mine set to 500 while charging and that is what it does. I just tested it by changing that to 125 and it went to 125 immediately when I plugged in the cable.

    I would recommend going to home screen and do menu/settings/applications/running and force close setcpu. Then reopen it and then select menu/Device Selection/autodetect speeds. The connect it to the charger again. If it doesn't go to the correct setting I would try to uninstall and reinstall setcpu.

    One other question, in profiles what is the priority you have your profiles and their priorities. Is it possible that you have some other profile with a much higher priority set?
     
  5. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,959
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    I just re-read your post and post number 2. Does your kernel not have a 500 slot?
     
  6. jttak82

    jttak82 New Member

    Joined:
    Jul 17, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    That's the weird thing. I do have a 500 slot. I might try uninstalling and reinstalling

    Sent from my droid using Tapatalk
     
  7. MotoCache1

    MotoCache1 Chief Droid Scientist

    Joined:
    Jun 30, 2010
    Messages:
    530
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    I think the pattern may be that when charging the Droid will not run any slower than the value of slot 3.

    Mine goes to 550 when running a 7 slot kernel with 250/400/550/800/1000/1100/1200. On a previous kernel that had 500 as the 3rd slot it would go to 500. If anyone doesn't know what slots they have they can look at the Info. tab in SetCPU and check out the list of values under "Time in State".

    If anybody with a 5 slot or any other kernel wants to take a look we can see if everyone fits that pattern (speed no slower than slot 3 while charging).