Setcpu is at 384(400mhz) when 100% charged?

Discussion in 'Android Applications Discussions' started by s-one, May 6, 2010.

  1. s-one

    s-one Member

    Joined:
    Nov 11, 2009
    Messages:
    256
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Hey all I'm trying to understand why setcpu does this at fully charged with profiles enabled and performance set. As soon as the battery is at 99% and below it goes up to my desired overclock.
     
  2. solorca

    solorca Member

    Joined:
    Feb 3, 2010
    Messages:
    328
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    North Carolina
    Ratings:
    +0
    My guess is that is the way that the system reads your underclocking profile. When charging, it can see that and underclock properly, but once you reach 100% while on the charger, it isn't actually charging, it's just maintaining the full battery. As such, the system is most likely simply reading 100% as you being in a state of maintaining battery level and it can't determine whether you're on or off the charger.
     
  3. s-one

    s-one Member

    Joined:
    Nov 11, 2009
    Messages:
    256
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    hmm ok and thank you for the info. For the Profiles I have:

    Charging 600 Max 550 Min
    Sleep/Standby 550 Max 250 Min
    Power < 100% 1000 Max 750 Min
    Power < 50% 750 Max 550 Min
    Power < 20% 550 Max 250 Min
    Failsafe 50c 550 Max 250 Min

    If charging it does use the 600/550 charging profile. If unplugged under 100% to 50% it does use the 1000/750 profile and so on. But if unplug at 100% it goes to 384/250. So weird. Does this happen to any else? Just me?
     
Search tags for this page

setcpu when charging