Phone "mutes" in middle of call

Discussion in 'Android Tech Support' started by becca, Jun 27, 2010.

  1. becca
    Offline

    becca New Member

    Joined:
    Jun 27, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I have had my moto droid for about 3 months and this is driving me nuts. I will be in the middle of a call and it is like my phone mutes itself. Except the mute button isn't pressed. The other person cannot hear anything from my end, even if I scream. Also, I have noticed that right before it happens, my phone vibrates like in "haptic feedback", but I don't have haptic turned on in my settings. The only way to fix it is to hang up and call back. Does anyone have a solution? I'm not covering the mic or anything, and as I said the mute button isn't green when this happens. Help please!!! Thanks
  2. Johnly
    Online

    Johnly Guest

    ...take it in and get it checked, it is under a year warranty, so nothing to worry about...
  3. jlaidlaw
    Offline

    jlaidlaw New Member

    Joined:
    Jun 12, 2010
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California
    Have you tried muting the call then unmuting? If nothing is working just return it like john said

    Sent from my Droid
  4. becca
    Offline

    becca New Member

    Joined:
    Jun 27, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Yeah, I tried everything, I found in another thread that this is a common issue and replacing the phone does nothing. Evidently will have to wait for a firmware update. Any chance Froyo will fix this? Or will I have to wait for Moto to do something? My phone isn't rooted, so I will have to wait for the "official" update.
  5. hookbill
    Offline

    hookbill Premium Member Premium Member

    Joined:
    Nov 30, 2009
    Messages:
    19,545
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    N.E. Ohio
    I don't know where you got the idea that this is a common issue. It isn't. I've never had that happen to me and as a matter of fact you're the first I've heard of it happening to. I've heard of other issues people have while talking but not this one.

    Let me ask you this. Do you have long hair? If so that could affect the proximity sensor and maybe your face is muting the phone. If that's the case just make sure your hair is either tossed to the other side or ponytail. My wife has long hair however and I've never heard her complain about this at all but from what I read that is an issue.

    As I tell most people, do a factory data reset and if that doesn't resolve the issue then do indeed take it back for a replacement. This just isn't a common issue.
  6. Jcassell1
    Offline

    Jcassell1 New Member

    Joined:
    Mar 8, 2010
    Messages:
    105
    Likes Received:
    1
    Trophy Points:
    0
    I have read in other post (Im not going to search and provide link in this post) about the same thing. This looks to be happening to more people than you think. The reason I know there are other posts on this same issue is because my phone and my wifes phone does the same thing. Pretty annoying when it happens and no long hair in the way or cheeks/ear hitting the mute button. Just goes mute during a conversation.
  7. ty.stebbins
    Offline

    ty.stebbins New Member

    Joined:
    Jul 1, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    This also happens to my wife on a regular basis. Especially on lenghty calls. We both travel quite a bit and I can't count the number of times this has happened when talking to each other. We swapped out her phone and now the same thing is happening again. I originally thought it was her. She is now in the habit of not even letting the phone touch her cheek and it still does it.

    She ends up having to mute and then unmute the call like jlaidlaw suggested. It may not be a common problem, but it is a problem...
  8. wlsblessed
    Offline

    wlsblessed New Member

    Joined:
    Apr 19, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I too am having the same problem and travel a great deal. Cannot figure out exactly what's going on but it is a problem. Also, I did noticed a few times that I had to unlock the phone before I could mute and unmute. Still searching for a problem.
  9. jsh1120
    Offline

    jsh1120 New Member

    Joined:
    Dec 9, 2009
    Messages:
    2,462
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Seattle, Washington
    Folks,

    Sorry to point out the obvious but if this problem (a) affects a small but significant number of users and (b) users who replace their phones encounter the "same problem," it stands to reason that's it is very unlikely that the Droid itself is to blame.

    In other words, if the problem were relatively common, affecting, say, 1% of the phones, the chances that one could get two phones with the same problem is .01 * .01 = .0001 or ten thousand to one.

    So that means that the problem is very likely associated with (a) the individual user; (b) the apps the user has on his/her phone; or (c) network issues common on the cell sites being used by the individual user. Frankly, these are the only features common to a particular user.

    If I were betting, I'd guess it's a network problem, especially if the "hair in the way" problem is ruled out. But it could be interference between a third party dialing app and the operation of the phone. If I experienced the problem, I'd take the precaution of uninstalling any apps that might be interfering with the operation of the voice functions and be sure that the screen is going black when the phone is being used.
  10. jsw111
    Offline

    jsw111 New Member

    Joined:
    Jan 18, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    This is a problem I am having too. I love my Droid and i'm a very experienced user. I have limited apps (under 20) and nothing that effects the way a phone call is made with the exception of Google Voice, no dialer, not rooted. They replaced my phone under warranty and I am having the issue again, however, it is only on lengthy calls. The only solution that works (some of the time) is muting and unmuting. It's very irritating and I think i'm going to bring it back again.

    If anyone has a permanent solution let me know.

    And 10,000 to 1 it's the user just sounds ridiculous. It's an issue with the phone
  11. vzwtek
    Offline

    vzwtek New Member

    Joined:
    Jul 23, 2010
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    0
    Whats happening on your droids is that the sensor that detects when you pull away from your face is too sensitive. What happens is that your cheek will hit that "plus sign" which is the add call button. it will mute your audio, but you will still be able to hear the other party. What i would recommend is downloading tedds droid tools. It puts a lock on while you are in call to prevent you hitting that button.

    If that doesnt do it, the other question i have is what is the call quality of the other caller, can you hear them ok?
  12. jsw111
    Offline

    jsw111 New Member

    Joined:
    Jan 18, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I just did a test on hitting the "plus" sign...and when that's done the microphone icon on the top right of the notification bar has a line through it indicating the call is muted. This is NOT what happens when my phone mutes itself. The microphone does not have a line through it, but the call is muted nonetheless. Additionally, the call quality on the other end is perfect.

    Again, I love my Droid but this is an issue I'm having for the second time...and it happened when I lived in NYC, and now I'm in Miami,both on Eclair and Froyo so I'd assume that would indicate the problem is not the network or the build.
  13. vzwtek
    Offline

    vzwtek New Member

    Joined:
    Jul 23, 2010
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    0
    did you even try the app? Motorola has not issued any tech bulletins for that issue. Before I would say its a "wide spread" problem, i would try a few things like that first.
  14. Dinomight
    Offline

    Dinomight New Member

    Joined:
    Dec 9, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    What ver of android are you running. I'm guessing 2.2. Because of a simple line of code changed in the release of 2.2 the phone has a new and in my opinion undesireable feature. What happens is that you are placing the phone to you face which turns off the screen but then chances are that you are holding it to your face using your sholder. In the old ver of android doing this wouldn't do anything. With 2.2 as soon as the phone goes horizontal the screen turns back on.... reguardless of whether or not the proximity sensor is active. your cheek then touches the mute or end call button, and there is your problem.

    Here is a test you can do.
    dial a number. then hold your had over the upper left corner of the phone.
    Your phone screen should turn off. now turn the phone flat (horizontal) but leave your hand covering the proximity sensor (upper left). Viola, the screen turned back on.

    When you do turn your head balancing the phone on your sholder, your cheek then touches either the mute or the end call button, which causes your problems.

    There is a way to fix this but it involves commenting out a line of the phone apk's source code then compiling it and replacing the existing phone.apk file with the new fixed phone.apk

    As far as i know there is only one 2.2 rom where the developer fixed the problem. (sumply stunning froyo).

    My wife has the same problem so i'm going to be placing a good phone apk on her phone.

    I guessing there is nothing wrong with your phone but your issue is with this dumb 2.2 code change.
  15. JenniB
    Offline

    JenniB New Member

    Joined:
    Aug 31, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I've been having the same problem and after checking like you said, i noticed you're right. Thanks :)
  16. vzwtek
    Offline

    vzwtek New Member

    Joined:
    Jul 23, 2010
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    0
    Just because you dont see an icon, doesn't mean its not happening. Tedds droid tool is free and has solved it for people who ask me about that, so....... do whatever you want or you can just complain constantly that that is not the problem.
  17. Dinomight
    Offline

    Dinomight New Member

    Joined:
    Dec 9, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Fix

    So i have a fix for the problem that should work on any 2.2 rom. Currently it requires you to use adb shell to remount the system partition as rw then copy over 2 apk files in to /system/app/ and then remount as r only. This is not really a big deal but i know it's not for everyone, so i am trying to package it as a zip that can be installed via clockworkmod or the rom manager. I'll post it as soon as i figure out why my zip isn't actually installing. Either way you will need to have root.
    -D
  18. spoyld
    Offline

    spoyld New Member

    Joined:
    Jun 10, 2010
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    0
    Been there, done that

    Mine just got replaced (and upgraded) for free to a Droid 2 because of that issue. Head back to Verizon and tell them you want it replaced as it is not a fixable issue.

    Let me know if I can be of more help.

    Good luck.

    Suzanne
  19. Dinomight
    Offline

    Dinomight New Member

    Joined:
    Dec 9, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    If you had this replaced and you're running android 2.2 the problem will arise again. It isn't a problem with the proximity sensor but with a change in the code in android 2.2(froyo).... below is the code inside the phone application that is causing the problem.
    Code:
    1156      * @param state current state of the phone (see {@link Phone#State})
    1157      */
    1158     /* package */ void updateProximitySensorMode(Phone.State state) {
    1159         if (VDBG) Log.d(LOG_TAG, "updateProximitySensorMode: state = " + state);
    1160 
    1161         if (proximitySensorModeEnabled()) {
    1162             synchronized (mProximityWakeLock) {
    1163                 // turn proximity sensor off and turn screen on immediately if
    1164                 // we are using a headset, the keyboard is open, or the device
    1165                 // is being held in a horizontal position.
    1166                 boolean screenOnImmediately = (isHeadsetPlugged()
    1167                             || PhoneUtils.isSpeakerOn(this)
    1168                             || ((mBtHandsfree != null) && mBtHandsfree.isAudioOn())
    1169                             || mIsHardKeyboardOpen
    1170                             || mOrientation == AccelerometerListener.ORIENTATION_HORIZONTAL);
    1171
    if you look at lines 1162-1171 you will see that the screen is turned back on if you the phone goes horizontal. if you take out the following from the code
    Code:
    || mOrientation == AccelerometerListener.ORIENTATION_HORIZONTAL 
    (line 1171) and recompile the problem is fixed. (thanks to chevy for finding the code.) I will post an update.zip file for clockworkmod recovery that fixes the issue for you.
  20. vzwtek
    Offline

    vzwtek New Member

    Joined:
    Jul 23, 2010
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    0
    BAM!!!! lol, jk. Just use tedds droid tools.
Search tags for this page

android phone keeps muting

,
droid razor is muted
,
droid razr maxx microphone mutes mid call
,
galaxy 3 keeps muting during phone calls
,

galaxy note 2 mutes itself

,
galaxy s3 mutes during calls
,
galaxy s4 mutes itself during call
,

note 2 mutes itself

,
razr hd muting itself during calls
,

samsung galaxy s3 mutes itself

,

samsung galaxy s3 mutes itself during call

,

why does my phone mute itself