Not receiving text messages in ginger with ud

Discussion in 'UltimateDroid' started by thejas, Mar 29, 2011.

  1. thejas

    thejas Member

    Joined:
    Jul 27, 2010
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    North East
    Ratings:
    +0
    For those of you who have been having issues sending/receiving text messages in Gingerbread or even Froyo (UD) I have found something interesting to possibly explain the issues. I had this issue even with Froyo (now running ginger). I've noticed that if you are using handcent (as I suspect many of you are) with on demand setting but have your minimum setting at 125mhz (if your kernel supports this low), many text messages don't make it through, or are extremely delayed. I think this is because the app or the phone in general needs more than that power to do text messaging and either the governor doesn't recognize the increased load requirement or handcent isn't "asking" for it. So your phone will try to send or receive to no avail. I think the reason they come back later is some other app/action taken on the phone is spiking the processor up enough to get those messages. I believe that handcent will try to automatically and continually try retrieve those messages on a polled basis....say every 10 seconds or so. What has solved the issue for me is setting my kernel to a higher minimum. I have found that 250mhz minimum and above will work fine. I do not know if this is posted somewhere else but this is my experience on UD 3.1.1 and 2.5 only! This may or may not work for you. Most of what was said here are assumptions and could just be completely wrong but hopefully, someone will get something out of it. You may have the same issue for any number of other reasons (bad signal anyone?) but this is just my experience. I have highlighted my solution for easy reference in the future. Let me know if this helps anyone. :)
     
  2. FATRAY

    FATRAY New Member

    Joined:
    Apr 25, 2010
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Baltimore, MD
    Ratings:
    +0
    I was having that problem all weekend, mainly Friday and Saturday, 25th & 26th. Then Sunday it seemed to be all better. I have my clock set at 250 - 800 on my Droid1. I figured it was the after market messenger I was using, after removing it and going back to the stock app it seemed all was right again. Any thoughts?

    Sent from my Droid using DroidForums
     
  3. thejas

    thejas Member

    Joined:
    Jul 27, 2010
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    North East
    Ratings:
    +0
    I'm not quite sure. I think it matters what kernel people are using too but I can't confirm that as I have had issues on multiple kernels from different devs. What after-market messenger app are you using? You could try a different after market app just to be really sure.
     
  4. u4icpain

    u4icpain New Member

    Joined:
    Aug 9, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I always set my min at 250mhz and I've never had this issue with either GB or froyo on multiple roms.

    ...so it sounds like u could be onto something
     
  5. neoaeon

    neoaeon New Member

    Joined:
    Mar 27, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I'm using Chevy's ULV 1GHz, my screen off settings are 250-550 (as I read a similar post elsewhere), the issue continues.

    My Rig:
    OG D1
    GPA14 (link)
    Chevy's ULV 1Ghz (03/24/11 link)
    ChompSMS (5.7 link)
    ~30MB Free internal
    ~27MB RAM Free typical

    I don't think it's the clocking, nor the non-stock SMS app. I've reviewed the databases with Root Explorer /data/data/com.android.providers.telephony/databases/mmssms.db the table is "sms". They never made it. The time column is in UNIX time with 3 extra digits for milliseconds, so change 1301439436662 to 1301439436.662 then paste it here Online Conversion - Unix time conversion

    you can see the telephony provider from android is receiving them late, or not at all, not the after market client.

    Below is a quote of my report for GPA that may be relevant here, it's appearing to be systemic with Gingerbread based ROMs.

    -neoaeon
     
  6. u4icpain

    u4icpain New Member

    Joined:
    Aug 9, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I'm guna go gb for a few weeks and report any issues. Only thing I can see (possibly) fixing this is going froyo or stock. I read recently in the news paper that the wireless device communication is getting so popular that the signals are starting to get dropped and have related issues... anyone support this theory?

    Sent from my Droid using Tapatalk
     
  7. thejas

    thejas Member

    Joined:
    Jul 27, 2010
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    North East
    Ratings:
    +0
    It's certainly a possibility. It should also be noted that I am on the pageplus network but I don't know that this really makes a difference given the fact that they use verizons network. For the people that have chompsms, have you tried a different non-stock messaging app (such as handcent?) It seems like this issue is so multi-faceted, that what solves this issue for some, is completely wrong for another (even on the same android os version). What I am guessing, is that other apps that run in the background with these messaging apps, are causing conflicts. The big questions of course are which ones and why are they doing it. Maybe a list of background running apps from everyone will help resolve this issue? If we see similarities we can start there...
     
  8. gimpyestrada

    gimpyestrada Member

    Joined:
    Nov 30, 2010
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Wichita, KS
    Ratings:
    +0
    This is a common complaint with Gingerbread based roms. The problem (as I understand it from reading other threads) is that Gingerbread is much more aggressive when it comes to managing memory (RAM not storage). The D1 doesn't have much in the way of memory and Gingerbread is trying to keep most of it freed up.

    Some people think they have come up with work arounds that seem to do well for them. The easiest would be to lock your MMS app into memory by checking the box for Lock messaging app in memory in Settings->Ultimate Droid->Performance settings.

    An alternative is to change the behavior of the memory manager. Check this post for some suggestions.

    Another thing that can help is checking the box for Allow purging of assets in Settings->Ultimate Droid->Performance Setting
     
    Last edited: Apr 8, 2011
  9. v941726

    v941726 Member

    Joined:
    May 29, 2010
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    i use chompsms and never have issues no matter what
     
  10. ItsTrentB

    ItsTrentB Member

    Joined:
    Jan 17, 2010
    Messages:
    217
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Southern California
    Ratings:
    +4
    How I got Handcent Notifications to work for me on U.D. 3.3.1

    I believe I solved the problem on my phone for missing text message notifications. It bugged me that My handcent notifications were not working and I'd just have a unread text message just sitting in my inbox, not knowing i received one. I even contemplated on going back to 3.1 or even Froyo 2.5 but Im still on U.D. 3.3.1 so maybe I can help ya'll out on this..

    First, I used a terminal command to set the memory management parameters back to stock Froyo.

    This is the proper command:
    su
    echo "2048,3072,6144,7168,8192,8192" > /sys/module/lowmemorykiller/parameters/minfree

    As seen as here, posted by GirLuvsDroid, Post #1007::
    http://www.droidforums.net/forum/project-elite/127616-rom-release-projectelite-v5-gingerbread-aosp-101.html#post1374180

    Second, I had auto killer.. and then I installed Advanced Task Cleaner from the Market.. I deleted auto killer because I didnt need it on my phone but thats optional to you but I figured it would still kill the Handcent app. What Advanced Task Cleaner allows you to do is ignore an app from being killed. So I long pressed on Handcent SMS, and chose to ignore this, as well as messaging and messaging widget [Yes, I know we can lock messaging into memory] So while advanced task cleaner is killing all other apps from running in the background, it avoids handcent SMS and messaging from being killed.

    Third, I did set my minimum overclocking to 400 but 250 works too, seeing I just checked it right now and its on 250 and all my messages are working.
    Also, Settings>Ultimate Droid>Performance>Check "Allow Purging Of Assets"..

    Lastly, Unfortunately, I did have to start over with Handcent. If you restored Data to Handcent using TB, it probably won't work, but you can try. However, I uninstalled using TB, and reinstalled Handcent from the Market and started from scratch..

    I rebooted into recovery because I WAS about to flash 2.5 cuz it didnt work, but I thought, "Mind as well make a backup while Im here" so I did that, rebooted into Android cuz I was waiting on an important text, and Voila! Everything worked again. Notifications came in and there was no need to flash another rom.

    ;]
     
  11. Nausicaa

    Nausicaa Member

    Joined:
    Sep 23, 2010
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I always lock my messaging application, on 125, used everything except handcent, and it works perfectly fine.
     
  12. Dj Carpenter

    Dj Carpenter Silver Member

    Joined:
    Sep 17, 2010
    Messages:
    2,446
    Likes Received:
    0
    Trophy Points:
    101
    Location:
    Texas
    Ratings:
    +0
    It does that because there isn't enough memory available.
    If the amount left is too low, you don't get them.

    One reason why GB isn't the best for a Droid. Still nice though.
     
  13. ItsTrentB

    ItsTrentB Member

    Joined:
    Jan 17, 2010
    Messages:
    217
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Southern California
    Ratings:
    +4
    Yeah i know, that's really too bad for the Droid 1. It's still running smooth right now but don't all GB roms start off that way? I wouldn't hesitate to slap froyo back on either.
     
  14. bodean

    bodean Active Member

    Joined:
    Nov 6, 2009
    Messages:
    1,155
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Chicago, IL
    Ratings:
    +0
    Is that memory command needed / recommended on Droid 1?
     
  15. ItsTrentB

    ItsTrentB Member

    Joined:
    Jan 17, 2010
    Messages:
    217
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Southern California
    Ratings:
    +4
    Not necessarily. If youre running Froyo, you don't need to use these commands. The command was only useful to be less aggressive, like Froyo, if were running any Gingerbread rom on the D1, due to aggressive task killing that comes with the GB.
     
Search tags for this page

android galaxy ginger bread isn't receiving texts

,

android gingerbread not receiving texts

,

not receiving sms from ginger

,

what if my android isnt recieving texts