keyboard issue, shift key not working as is most punctuation

Discussion in 'Droid 4 Tech Support' started by telivi, Mar 23, 2013.

  1. rongotti

    rongotti Active Member

    Joined:
    Aug 3, 2011
    Messages:
    108
    Likes Received:
    41
    Trophy Points:
    28
    Ratings:
    +42
    I am still having the same issues with FB Mobile :-( shift will not work unless I hold it and press the key at the same time and caps lock is dead

    Sent from my DROID4 using Tapatalk 2
     
  2. zertsman

    zertsman Member

    Joined:
    Apr 30, 2011
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    set to No Language.. didn't help me.

    any suggestions?
     
  3. NeoPhoenixTE

    NeoPhoenixTE Member

    Joined:
    Dec 20, 2010
    Messages:
    255
    Likes Received:
    24
    Trophy Points:
    18
    Location:
    Fort Collins, CO
    Ratings:
    +24
    If you're still having physical keyboard issues, I found a way to get it working as best as you can.

    Settings > Language & Input
    Under the "Physical Keyboard" section, check your "omap4-keypad" setting. If it's anything but "Default" (this includes "English (US)"), then tap on it, and then tap "Set up keyboard layouts"
    This will give you a list of languages. Uncheck ALL of them. Then hit back.
    This should now leave you with just "Default" checked.
    Back out of your settings and you should be good to go!

    This fixed my issue with the , and . keys not doing ; and : when hitting shift (kept giving me < and >). Haven't had any physical keyboard problems since. Mind you, I still have to hold shift down in any Chrome-based windows, but I think that's purely a Chrome issue now, and not a D4 issue. :p
     
  4. ingrids

    ingrids New Member

    Joined:
    Aug 14, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I had to make some of the changes as previously mentioned AND uninstall chrome.
     
  5. bassbass

    bassbass New Member

    Joined:
    May 1, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ypsilanti, MI
    Ratings:
    +0

    This ish has been a thorn in my side since I downloaded the jb update and I can't tell you how happy I was to find this page and try out the last couple of fixes posted by kettlnaut and NeoPhoenixTE. However, there's only been partial success. My shift key is working again when I text with my physical keyboard (as with others, *the* reason I got this phone) but the shift key still is refuses to work like it used to when I with my browser. I feel like I have made the right changes in the Language and Input settings, but here it is for perusal:

    Under the Keyboard and Input Methods my phone is showing:
    : Default (No Language (QWERTY) - Android Keyboard (AOSP))
    : Android Keyboard (AOSP) No Language (QWERTY)

    Under the 'Physical Keyboard' section:
    : mapphone-switch: default
    : omap4-keypad: default

    It looks like it the keyboard should be working again in all scenarios but it's not....am I missing something? Also, the browser I use is just the browser that came loaded on the phone....I've never downloaded anything else...could that be part of the issue since the keyboard shift problem only seems to be happening when I am using that browser?
     
  6. rongotti

    rongotti Active Member

    Joined:
    Aug 3, 2011
    Messages:
    108
    Likes Received:
    41
    Trophy Points:
    28
    Ratings:
    +42
    Mine is still having the same issue, seems like no one has a fix for it :mad:

    Sent from my DROID4 using Tapatalk 2
     
  7. zertsman

    zertsman Member

    Joined:
    Apr 30, 2011
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I haven't taken the time to gripe at verizon yet... but yess. Still have the problem.

    Sent from my DROID4 using Tapatalk 2
     
  8. kettlnaut

    kettlnaut New Member

    Joined:
    Nov 1, 2012
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Haven't tried the suggestion back there about the omap4 setting, hoping to try that soon here but been playing with some roms hoping to find a friggin peice of software that works on this thing. Let's just say I am starting to have severe buyers remorse over this phone. How many years after they release it will it take to get the damn thing right? By the time they do it will be well out of life-cycle and support. ROFL.

    Anyway it seems to me the trigger is when I go from doing the physical keyboard to doing any kind of onscreen typing interaction. I notice the change instantly if I am in texting. Like if I close the phone and want to one hand it as soon as I use the onscreen keyboard my shift key is all jacked up again. So dumb how hard is it to fix this? Like none of the other droids have a physical keyboard so they all work? Such total bologna.
     
  9. kettlnaut

    kettlnaut New Member

    Joined:
    Nov 1, 2012
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    And over the verizon forum they have finally caught wind of it and they too say to uncheck all the languages in the omap4 settings. I dont think I have done anything with omap4 yet, just the AOSP stuff. https://community.verizonwireless.com/thread/796564
     
  10. kettlnaut

    kettlnaut New Member

    Joined:
    Nov 1, 2012
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    OK don't quote me on this, but this might be it. Thought that before but now that I know the specific triggers I can say what is what isn't much better. And it seems to work even in chrome now. SO here is the deal. Went into the input settings, and everywhere I could change a keyboard default language, I forced it to US english. So go to the AOSP, the omap4, the mapphone-switch and go and make sure that ONLY English US is chosen for keyboard layout. Then go into google voice typing, uncheck the auto language and choose us english. Now my chrome WASN'T updated what I tried this so hopefully installing the updates doesn't break it, or if it does hopefully I can just go put all these settings back and be good, but I was able to transition between physical and onscreen typing without it goofing my shift key up after doing this so that is good news to me!
     
  11. kettlnaut

    kettlnaut New Member

    Joined:
    Nov 1, 2012
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    OK so that is conclusive in my eyes. You do have to uninstall the chrome updates and of course turn off the autoupdate feature, but if you want to use it and are ok with the old version shift seems to work even in chrome with all the other settings I listed set specifically on english, and it works in fb. BUT I seem to see the issue others are seeing with the wrong character getting > instead of : so I guess maybe we need to keep trying different keyboard layouts? Can someone make a flippin custom key layout that is RIGHT? How hard is this really? Sheesh D:
     
  12. Steeler1

    Steeler1 New Member

    Joined:
    Jun 10, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I had this issue as well. Go into settings, then language & input, go down to omap4-keypad. Make sure it has default underneath it, if not touch it to access it. Make sure everything in unchecked, if not uncheck it. That solved my problem
     
Search tags for this page
android keyboard shift key not working
,
android shift key
,
android update shift key not working
,
droid 4 keyboard shift not working
,

droid 4 shift key

,
droid 4 shift key fix
,

droid 4 shift key not working

,
droid shift key not working
,
shift key not working android
,
shift key on droid 4 not working