Forcing LTE on Verizon S3

Discussion in 'Samsung Galaxy S3' started by Archerofthemoon, Sep 16, 2013.

  1. Archerofthemoon
    Offline

    Archerofthemoon New Member

    Joined:
    Jun 30, 2010
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Due to the fact no ISP provides internet service to my area I use my S3 (well any phone at the time) as an access point via Klink. The problem I tend to have is that I'll be browsing the web or streaming a movie then the S3 decides to go into 3G or 1x service. I tend to have to reboot the phone, and or toggle the airplane mode setting to get it back to LTE, but it doesn't always work.

    Is there a way to force the S3 into always being on LTE? I know I have a strong LTE service signal where I'm at as friends who have come over get blazing service and I tend to when it stays in LTE. With a bit of searching I found threads and videos referring to "Phone Info" as an app, but it looks like it has been removed from the Play store. Is this a solution I can use? Or is there another way? I've gone through the network settings and set the device to CDMA only and tried Global, but they are only temporary fixes until the phone decides to switch.

    A solution to this would be greatly appreciated.
  2. legalkill
    Offline

    legalkill Member

    Joined:
    Feb 5, 2010
    Messages:
    215
    Likes Received:
    9
    Trophy Points:
    18
    Location:
    Kennesaw
    The issue would be that I am not sure that it would improve your signal. The times that you go to 3g or less is that there is no LTE signal detectable by the phone antenna and if you restrict it to lte only you would just have nothing. PM me and i will send you the version i have.
Search tags for this page

force lte s3

,

force lte signal s3

,

galaxy s3 verizon force lte

,

how to force lte on galaxy s3

,

how to force s3 to use lte