1. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Droid 3 in Aruba

Discussion in 'Motorola Droid 3' started by mchamoff, Sep 9, 2013.

  1. mchamoff
    Offline

    mchamoff New Member

    Joined:
    Sep 7, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I am in Aruba with the Droid 3 (xt860). I have purchased and installed a SETAR SIM card, purchased a prepaid data plan, set up the APN's and selected GSM/UMTS. Phone seems to work when I select GSM ONLY but only gets EDGE. When I select GSM/UMTS, it shows SETAR 3G in the search but selecting it causes no service. Took the phone into 3 SETAR locations here and they said the phone is only capable of EDGE. Does anyone know if this is true. I would really like to get 3G. I paid for a 14Meg data rate with 4GIG for 1 month. Thanks

    **************************************************************************************************************

    Well - 3 days later finally got this going - took a lot of research and trial and error. For those interested in having a data capable phone in Aruba. As most of you know Aruba is still one of the most expensive places to call into and out of - with US carrier (Verizon etc.) roaming rates. So it is quite nice to have a reasonably priced solution while here for extended periods.

    I purchased the Droid 3 new on ebay for use here. It had a strange system version showing (test keys etc) that didn't come up with google or forum searches. So my idea was to upgrade it to the latest GB version 5.7.906 for the phone and maybe everything would work. The OTA update didn't work and only showed a blank screen. First I tried rooting, downloading CWM, Rom Manager, Titanium backup and some other CWM reboot stuff and made several backups. Research on the subject finds many broken links and sales pitches and downloads for Ilivid, which by the way is very hard to remove from your computer. Finally I found the ovelayer post and did a fastboot for the ovelayer Official .906 1_click sbf .exe. This partially bricked the phone. Then I tried to restore from my backups for the old strange but working (in GSM) level but couldn't get into Rom Manager or CWM from the boot screen and the backup wouldn't restore with the normal Motorola recovery due to being "unsigned". Don't understand why all my backups were no good. Tried the ovelayer one click and the restore several times more with no luck. Went to bed and left the phone plugged into the computer. Got up in the morning and the phone battery was dead and the fastboot was saying couldn't flash with low battery. Thought I would have to pack it up for this trip - but did more research and found a post by Stein1071 in androidforums entitled "Unbricking/SBFing the DROID3 (Or returning to stock without a Nandroid)". Post had good links for 5.6.890 and a procedure. But how to deal with the problem with the dead battery? none of the googled options were viable here in Aruba with no tools and no external battery charger. So I tried anyway - phone in fastboot - did the update as described by Stein1071 and the phone just sat there for about 5 minutes but the charging light on the side went on. Then after 15 minutes, or so the software upgrade screen came on with the status bar moving. After a few minutes the screen went blank again for 15 minutes, then the software update screen came on again with the status bar moving. It was like the update was waiting for the battery to catch up and it would resume. Who knows??? Well after awhile the phone reboots into 5.6.890. Then I do a manual check for OTA updates and it says 906 is available. SO I download and install 906 and the phone came up in 906. Put in the SETAR SIM and everything works fine. GSM/UMTS/HSPA works great 1100kbps down and 278kpbs up with 2 bars. Nice to have data away from the hotel.

    Anyone need some slightly used root software??? haha
    Last edited: Sep 12, 2013
Search tags for this page

driod 3 work better without sim card installed?

,

droid 4 with setar sim

,

setar data packs aruba