D2G GPS Issues

Discussion in 'Motorola Droid 2 Global' started by MerkXR4, Nov 10, 2011.

  1. MerkXR4
    Offline

    MerkXR4 New Member

    Joined:
    Feb 27, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    All -
    Current setup: D2G with CM7
    I SBFed to .330 and did the OTA to GB. From there, rooted using 1-click D3 method, then installed CM7 zip and gapps zip.

    My issue is that the GPS functionality is pretty much zero. My easiest test is to enable GPS and then go into Google maps. Within seconds (probably about the amount of time for GPS to normally 'start' its search for satellites) the unit shuts off and does a full reboot.

    My thought is that GPS never gets initialized by the device until I attempt to get a location through Google Maps. This is confirmed by trying to take pictures with a tagged location, and it never finds a location, and also by using GPSCompassMap (a free app). This app never finds my location either. In addition, I NEVER see the little compass icon up in the taskbar.

    I do not believe this is an issue with having CM7 installed. I was previously on the leaked version of GB before the OTA was available for everyone and it was giving me the same issue then. I can't say I've tested this on .330 before customization, and won't be able to test this until after the weekend because I am traveling. I am hoping that there is a fix I could do so I can use the GPS while traveling this weekend.

    Thanks in advance!
    Last edited: Nov 10, 2011
  2. MerkXR4
    Offline

    MerkXR4 New Member

    Joined:
    Feb 27, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Just SBFed back to .330 and the problem is actually worse. While the satellite shows up immediately in the taskbar unlike when I was on CM7, shortly after the satellite shows up there the phone starts bootlooping. The only way to stop it is to quickly power off the GPS on one of the restarts.

    This is my second replacement from Asurion already (first replacement was because the keyboard back light didn't work). Looks like I'll be onto my 3rd replacement sometime next week. :p