UD 3.2.5 Exchange Sync says 'Unable to open connection'


New Member
Jun 14, 2010
Reaction score
UD 3.2.5 & 3.3.0 Exchange Sync says 'Unable to open connection'

So, just upgraded from 2.5 to 3.2.5. Unfortunately when I try to add my university's exchange email account (which is, sadly, run through Microsoft Outlook Live or whatever it's called), I get a message after the 'Checking incoming server settings...' screen that says: Setup Could Not Finish - Unable to open connection to server.

Is this a known bug? Does Exchange work for anyone else? It's always worked perfectly on 2.5.
I found a solution. If you are getting either the above stated error message, or one along the lines of an authentication error, try these instructions: laur.ie's blog » Fixing Android 2.2 Sync after Upgrading to Exchange 2010 SP1

It seems that Exchange Server 2010 SP1 and UD's Email.apk have issues communicating. This worked for me on UD 3.3.0.

P.S. Is there a bug tracker or any way to report this to the ROM creator(s)?