Droid Incredible will not connect to Exchange


New Member
Jan 28, 2011
Reaction score
HOW TO: SET UP BLACKBERRY EMAIL ON DROID (I've read the FAQ about setting up Exchange)

-I have corporate Blackberry email (BES) and had a BB Bold and now an Incredible. (I own the blackberry it’s not corporate issue). We have access to our email through web base Microsoft Exchange.

-I can’t seem to get the email to work. I’ve searched the forums and can’t find out why.

-ERROR WHEN CONNECTING: “Failed to Connect to the Exchange Server. Please check Exchange Server settings”
-I do have web access through Microsoft Exchange. Info below:

Mailbox owner: [[email protected]]
User-Agent:Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0C)
Outlook Web Access experience:Basic
User language:English (United States)
User time zone:(GMT-05:00) Eastern Time (US & Canada)
Exchange mailbox address:/o=AFTCO/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=myname
Outlook Web Access host address:https://mail. mycompany.net/owa
Outlook Web Access version:8.1.436.0
Outlook Web Access host name:mail.mycompany.net
Client Access server name: ex01. mycompany.local
Exchange Client Access server .NET Framework version:2.0.50727.3615
Client Access server operating system version:Microsoft Windows NT 5.2.3790 Service Pack 2
Client Access server operating system language:en-US
Microsoft Exchange Client Access server version:
Client Access server language:en-US
Client Access server time zone:Eastern Standard Time
Microsoft Exchange Client Access server platform:64bit
Mailbox server name: ex01. mycompany.local
Mailbox server Microsoft Exchange version:
Other Microsoft Exchange server roles currently installed on the Client Access server:Mailbox, Hub Transport
Authentication type associated with this Outlook Web Access session:Basic
Public logon:Yes
--- In the Droid I tried to set up and Exchange ActiveSync Account
Email Address:
Server Address: ex01.mycompany.local
Domain: mycompany.net (i've also tried ex01.mycompany.local)

SSL is checked