Tethering after JB update?

kanuck

New Member
Joined
Jan 15, 2013
Messages
20
Reaction score
0
Location
Canada
I admit it... i couldn't wait.

updated to Jelly Bean today via the downloaded zip file. tried to do it right: unfroze bloatware, switched back all system changes (including tethering entitlement check), used voodoo to backup root and temp unroot. recovered to the zip file and was able to restore root no problem. JB seems to run a touch faster, but not a very different experience.

moto tether app is a problem, though. usb tethering option is gone completely. wifi hotspot proclaims to work (after removing entitlement check via SQL), but while my computer connects, it doesn't get internet access.

in my search for a solution i tried both Wifi Tethering for Root and FoxFi with the same results (Wifi Tethering reports adhoc fail). EasyTether worked, but sporadically at best.

anyone have a tethering solution?

oh... in case it matters i've unlimited data with Rogers GSM here in Canada. never had trouble with the stock app on ics once i got rid of the entitlement check.

thanks in advance...
 
Wifi Tether worked fine for me. I had to set the profiles up to use the generic ICS/JB settings.
 
WiFi Hotspot entitlement check hack still works on my Droid 4. I didn't revert those settings, I didn't defrost frozen apps and I didn't unroot. Applied the update as it was pushed to my phone, rebooted and restored root with OTA Rootkeeper. All my frozen apps are still frozen and my WiFi Hotspot still works (as tested connecting my tablet to my phone and browsing the web).

Not sure why it's not working for you after editing the database file again and making changes to the dhcp range from the defaults...

Here's what I had followed back on Gingerbread and it's remained functional through ICS OTA and now the JB OTA..

WiFi-tether...


open sqllite and scroll down to settings an storage (you want the one with the hammer and wrench not the one with the gear icon)
select it
select settings.db
settings
scroll down until you find entitlement check, it should be around value 150 and then change the value in the 3rd column from 1 to 0 (long press the 1 until edit field pops up) save and then reboot
select the moblie hotspot and when you set it up, make sure you change the dhcp from 192.168.42.2 to 192.168.99.2 or it wont work.
 
e5atyjer.jpg


That's what it's hittin' for on my phone. Got me stuck on stuck mode.

Sent from my DROID4 using Tapatalk 2
 
After removing entitlement check via SQL, my Wifi tether worked great. I still have USB & Bluetooth tethering available and working as well.
 
I started out on ICS .217 rooted with Safestrap and CM10.1. Backed up everything via TB. Removed safestrap then reset to factory default. SBF'd to ICS .217 stock. Upgraded to JB OTA using MyFishBear's upgrade files. Then I reset to factory once JB had fully installed. Then I did the basics and restored with TB after deleting the system file back ups that no longer existed on JB. Hope that helps someone with there upgrade process if there having trouble.

If I ever get time I could post a nandroid backup so you can just use that and hopefully the options would come back for ya.
 
Is there a step-by-step tutorial out there for a dummy? I'm coming from a stock ICS phone that I just recieved as a replacement.

Thanks all.
 
Alright finally got the time to do a Nandroid/Safe Strap Backup for you. This back up is the OTA Stock Jelly Bean 98.72.18 with root and usb, bluetooth, and wifi tethering all working.

https://docs.google.com/file/d/0B_xvg1mYV-6PajExNGw2cXJNRjA/edit?usp=sharing




N
OTE: If anyone else wants to host this your more than welcome to. I have limited hosting space so I'll eventually have to delete it.
 
I'm not the programming type.

Is there a tutorial on how to install this?

Thanks.
 
I'm not a 100% if this would work if you're currently still running ICS. I'd hope a more experience developer would confirm the ICS side of things before you try it, but once your on JB. But you would need to download the back up, place it on your SD card, be rooted, and running Hashcode's Safe Strap then you would Power Off and Turn on your phone. Hit the menu key to open safe strap. Click the recover button, locate the back up file you placed on your SD card earlier and start it. Once the process is finished you would reboot your phone and you should be running JB with root/tether.

Note the above instructions would delete all your apps and personal data so back up with Titanium Backup before trying.
 
just a quick update.

After bricking my phone by changing some system files (d'oh!), i managed to follow instructions and reflash jb via rsd. Awesome!

USB tethering seems to have reappeared as a result, but I've lost root so I can't dispense with Verizon's authorization check. Back to square one of sorts, but glad to not be bricked anymore...
 
Sigh... still struggling.

Rooted now, thanks to the Razer 4.1 Exploit that happens to serve us too. Installed SQL, zeroed the entitlement check, but still a no go. PC connects to the network fine (via USB or WiFi now) but doesn't find a website. APN settings are fine for on-device browsing and were good for tethering in ICS as well as the LG L7 running JB I got as a loaner.

What gives?! Maybe a Rogers or GSM compatibility issue?
 
At this point, i'm saying ..screw JB. There doesn't seem to be anything to gain and there are a ridiculous amount of issues.
 
Back
Top