Droid 4 - JB - No Wifi Tether??


New Member
Jul 9, 2012
Reaction score
I'm sure this has been posted dozens of times already, and I apologize for this, but I'm in a crunch.

I have no internet available at my house without using wifi tethering via my Droid 4. I have unlimited data, and don't wish to pay anymore than I already do on this outrageous phone bill. My question is: Do I try to hack my phone (Last time I rooted a phone was a Droid X2...), Do I suffer and use the USB tethering offered via FoxFi/PDAnet? Is there another alternative? I hate being tethered via cables, as I constantly need to use my phone to talk/text, and having a cable attached to it at all times is rather bothersome.

I am willing to do a rooting method, provided there's a relatively easy one to do. I've read threads regarding the entitlement check, I've read threads that offer magical root methods that fix all of the problems I'm having, even been suggested that I go back to ICS I believe it was. Right now, I'd even be willing to pay someone to fix this! LOL

Any ideas? Please be gentle.
I don't know if anyone got back to you about this, but the last time I checked Foxfi and PDANet both allowed Wireless.
Foxfi doesn't work with JB.

JB seems like a mess to me.
1) Root with razr_blade root method.

2) purchase sqllite editor from the Play Store

t Requires root so that's why you need to root first.

3) Follow these steps.
open sqllite and scroll down to settings an storage (you want the one with the hammer and wrench not the one with the gear icon)
select it
select settings.db
scroll down until you find entitlement check, it should be around line 66 and then change the value in the 3rd column from 1 to 0 (long press the 1 until edit field pops up) save and then reboot
select the moblie hotspot and when you set it up, make sure you change the dhcp from to or it wont work.

4) Tether using stock/built in WiFi Hotspot app.
Last edited:
I tried the method using SQLite editor in the last post and I get an error:


An error occured while opening the database. disk I/O error (code 3850):, while compiling: SELECT * FROM sqlite_master WHERE type in('table', 'view') ORDER BY name"

I will post if I find anything. But so far nothing I have tried works.
Are you rooted?

Your best bet would be to flash the JB fastboot files and start over from the beginning. It sounds like something is corrupt on your device. I did the OTA and restored root with OTA Root keeper and my settings were still intact (used sqllite to check the setting as well as testing tether). I then fast booted the stock JB fastboot files, wiped my system completely, re-rooted with Razr_blade and applied the edits with sqllite. Checked tethering and all works.

If it's not working for you, something is wrong with files on your device or you are doing it wrong.

Works on my D4, my wife's D4 and my sister's D4.

Sent from my Nexus 10 using Tapatalk 2
I'm trying to follow your methodology, but every time I go into the settings storage, it says no databases found. What now?
Nevermind, I restarted the program and it worked. No idea why it didn't the first time it booted. Bizarre.
OK so I'm at a loss. I followed your instructions to a point, but I'm unclear as to what program I should be running. What is "mobile hot-spot"? I have the wi-fi tether program that worked with previous OS' but running that now, still does nothing. Furthermore, there is no way to change to the address you stated, in this program. This only has a drop down menu of LAN addresses from which to choose, and isn't one of them. Neither is for that matter. This leads me to believe you're running something different so I'm curious to know what it is so I can get this going. Thanks in advance.
And nevermind. I see you were using the motorola stock mobile hotspot. I had disabled it. Back in business. Sorry to be a bother.
I'm having the same problem. I have a Razr HD + root. Installed SQLITE Editor. Scrolled to "settings storage com.motorola.android.providers.settings". Tap on settings.db and I get "no table found. An error occurred while opening the database. disk i/o error (code 3850):, while compiling "select * from sqlite_master where type in ('table','view') order by name"

Any suggestions?
Never mind. I was using an old version of sqlite editor. I upgraded to the current one and the hack worked.