Superuser not working on certain apps


Active Member
Dec 11, 2009
Reaction score
Tucson, AZ, USA, Earth
Current Phone Model
Sony Xperia XA2 Ultra H4233
Okay, here's the shake down. I've been running Bugless Beast version 0.4 on my Moto Droid for about two weeks or so and everything has been working beautifully. All my apps that require superuser permissions worked fine. I'm not sure exactly when it started or what I did that might have caused this but I first noticed it when I updated one of the apps that requires root called AdFree. When I clicked the app icon after the update instead of asking for superuser permission it just immediately shows a popup saying it can't access root. I went to the SuperUser Ninja icon and it shows AdFree in the whitelist but for some reason the app errors out. I assumed it was a problem specific to that app but when I run Better Terminal Emulator Pro and type "su" it says permission denied and it's in the whitelist as well. What's really weird is that superuser works fine via adb shell and EStrong File Explorer. another app that fails to run is Titanium Backup. I uninstalled AdFree, rebooted the phone and reinstalled it but it still fails. I'm thinking about creating a nandroid backup and then reinstalling BBv0.4. Does anyone else have any ideas what's going on and how I might be able to fix it?


So I went ahead and did a nandroid backup and then reinstalled BB over the existing install and it went flawlessly and still retained all of my customizations, settings, and data. After that I ran the apps that were giving me trouble and they all work with superuser again. I still don't know what caused the problem but I was able to correct it.
Last edited: