Stock Gallery Crashing


Silver Member
Nov 2, 2010
Reaction score
North Carolina
What's up everyone. Has anyone had their stock Moto gallery crash on them consistently? I have restarted, booted into the boot loader menu, restarted again, and cleared cache. Does anyone have any suggestions on how to get the gallery back up and running. My SD Card is encrypted and I have cut the encryption to try to get it up and running along with leaving it encrypted. Any suggestions?

Any help is greatly appreciated,

Sent from my T2
Might have a corrupt file in there. Use a file explorer app or QuickPic to view the contents of your gallery and delete any files that are not familiar to you or don't remember taking.
Thank you so much man I didn't even think about a file explorer. Any particular you would recommend? Astro or any other? Thank you again

Sent from my T2
I can open all my photos in the Google Photo app just not in the Moto gallery. Kinda of strange. Running Nova Prime, empire 6 icons and still locked boot loader

Didn't see any corrupt files in the phone or SD Card memory though

Sent from my T2
It does sound like there is a corrupted file in the Moto Gallery App. If everything works in QuickPic, you can backup your data and do a Factory Reset which should fix the issue. OR, just use QuickPic as your gallery App.
Have you updated to the new Gallery app? I think there is an app update out now.
Thank you guys for the help. I have searched through Astro file manager for over an hour so far. I can't find any corrupt files in the device memory or SD Card. Is there a good way to find a corrupt file? Maybe a better file manager that would show it? Still can't access the gallery. It just tries to load then crashes. Would hooking it up to the computer be a better way? First time I've had an issue of a corrupt file and not been able to find the source

Sent from my T2
I did go through and uninstall the updates to the gallery and tried opening it after restarting with no success. Also reinstalled updates then restarted and had no luck on opening it

Sent from my T2
Would optimal zooper widget pack, chrome dev, empire icons, emperial icons, or empire zooper have any effect? Those are the only apps I've installed recently

Sent from my T2
You didn't move the app to the SD card by any chance..??
The gallery app isn't able to be transferred over to the SD Card. I got it hooked up to the laptop now trying to figure something out. Would a bug report help on this situation?

Sent from my T2
Still no corrupt photo files or system files even looking through everything on through my laptop. Gone through the whole phone and looked through the bug reports. The gallery isn't even starting to enter the bug report or crash reports.

Has anyone heard of any software viruses or anything? That is the only thing I can thing of??

Sent from my T2're right..i saw the button ..but didn't pay attention to the fact that it wasn't lit lol.
It's all ok man I appreciate the thought. I can't figure out what's going on. Do you think its worth running the Software Repair Assistant from the laptop? I am doing everything I can think if to keep from having to delete all my user data and doing a factory reset

Sent from my T2