River dunked and bricked?


New Member
Jul 26, 2012
Reaction score
New to the forum but not to technology. I had a Rezound. Great phone. Loved it. Did a lot of research and chose it over the Razr, and Nexus back in November. It was the right choice. Look at the resale values of those 3 phones today. Anyway, I was kayaking down the river (and I had everything in a water-tight bag) when I spied a mature bald eagle in a tree right next to the bank. I paddled up river (huff, huff, huff, huff) and positioned my kayak against a log next to the bank. Grab my phone out of the bag, and as I was about to snap the picture, the current flipped my kayak over. I couldn't see it, but I was positioned against a smaller branch that was at a 45degree angle against the log. The kayak went down. I went down. The phone went down. It was only for a about 3 seconds, but I have been unsuccessful at getting the Rezound back to life. Here's where I am at:

The phone was Unlocked, rooted, S-ON, running Scott's CleanRom 4.5. with the Gingerbread patch applied. Amon Ra 3.13.

I took out the battery, SIM, and SD card and let it dry (used the bag-of-rice trick also). I even pulled the red cover off (voided any warranty which I'm sure I didn't qualify for at this point anyway). Have let it dry for 6 days. It will boot to the second HTC white screen and then reboot. I can get it into the bootloader and use fastboot to flash image files, etc... I have tried unlocking/relocking, flashing various images to boot/system/recovery. But I cannot boot into recovery to flash the ROM. Every time I choose "Recovery" the phone reboots.

Also, at this point, I'm not sure if the USB is charging the battery even though I have access via the SDK/fastboot from the PC. I do have the SD card available to me, but using the PH***.zip file doesn't seem to help. I've become rather adept at using the "fastboot" command. Can't use the "ADB command, I imagine that is due to the fact that I can't boot the phone all the way up into debugging mode.

Now, I still have some confusion regarding version numbers of the boot.img, ROM, system.img, recovery images, etc... So, maybe there's still hope, but my hopes are not high. Right now using a S3 with a few days left on my 14 day return period. Not sure if I want to stick with it or get a replacement Rezound.

Here's what info I can get from the bootloader(HBOOT) and fastboot:

*** UNLOCKED ***
Oct 6 2011,15:43:22


<vol up> to previous item
<vol down> to next item
<POWER> to select item



*** UNLOCKED ***
Oct 6 2011,15:43:22


<VOL UP> to previous item
<VOL DOWN> to next item
<POWER> to select item



fastboot devices yields "HT19XS218463"

Help is greatly appreciated. Mr Smith????? (-:
Some more info I forgot to include.

C:\android-sdk_r16-windows\android-sdk-windows\platform-tools>fastboot getvar all
(bootloader) version: 0.5
(bootloader) version-bootloader: 2.11.0000
(bootloader) version-baseband:
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 3.14.605.5
(bootloader) serialno: HT19XS218463
(bootloader) imei: 990000336615556
(bootloader) product: vigor
(bootloader) platform: HBOOT-8260
(bootloader) modelid: PH9810000
(bootloader) cidnum: VZW__001
(bootloader) battery-status: good
(bootloader) battery-voltage: 4011mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-bc948b45
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.512s
Friendly Bump

I know I could probably attach this thread to one of the "flashing/custom ROM" threads, but I don't want to hijack another thread, and my problem isn't really about flashing, but more about is there something I can do via software to fix my Rezound which is suffering from maybe a hardware problem (It got wet).
Sorry for the late reply but try running a stock RUU(you can probably still get them from scottsroms.com)
Sorry for the late reply but try running a stock RUU(you can probably still get them from scottsroms.com)

Tried flashing Vigor_Stock_Doedexed_3.14.605.5.zip by copying it as PH98IMG.zip to my SD card. It seemed to flash okay. But my phone still only boots to the second HTC white screen and then reboots.

I can boot into fastboot and flash individual partitions.
I can boot into bootloader. But as soon as I choose 'recovery' my phone reboots.
I tried reflashing recovery-ra-vigor-3.14-gnm.img to the 'recovery' partition, but no luck.

I will try an older stock ROM as I thought 2.01.605.11 was the latest, not 3.14.605.5.

Should I be locked or unlocked? Should I be using rooted or non-rooted ROMs?

Is there a way to repartition the internal storage or to at least verify/check it?
Well, I think I made some progress. I locked the bootloader, then placed the RUU_Vigor_3.14.605.10_PH98IMG.zip on the external SD card as PH98IMG.ZIP and booted into bootloader. The flash seemed to do its thing, it unzipped and went through a list of unzipping/writing to different areas of the internal structure. It did 5 of them and then rebooted and did all of them. Each one said "OK" on it. It asked to hold the power button reboot which I did, and it does the same thing. Just boots into the second HTC white screen and then reboots. I may trying pulling the boot.img out of that file and flashing it separately. Still can't get into recovery.