Possible ad exception fix for Audiogalaxy app?


Apr 17, 2010
Reaction score
Hey guys! UD blocks Audiogalaxy as an app because it thinks its an ad. I realize there is a fix using Root Explorer but it is extremely tedious and involves scrolling throw multiple lines of code on the phone itself.

Doing it once was not a problem since it worked, however everytime the app is updated this fix has to be redone making it very frustrating. Is there a possible fix that could be done with an update.zip that would edit the host file to exclude blocking this app?

Thanks guys! I'm loving UD 2.5 BTW!

This is the fix taken from Michael Campbells post

"If you have root explorer, follow these instructions. Note that this works for BB or UD both.

First, make a nandroid backup! Don't skip this step. Don't blame me if you do!
Open root explorer
navigate to /etc
mount the filesystem as r/w
find the "hosts" file. Long-press and "open in text editor"
scroll down to the entry that says: audiogalaxy.com (This may take awhile; I scrolled down with my finger the normal way, then a combination of tapping and D-pad got the cursor down there.)
Remove this line (i.e., use the backspace key to remove it)
Scroll down to the entry that says: www.audiogalaxy.com
Remove this line (just like step 6)
Save & exit (from the menu)
[optionally] remove the hosts.bak file
navigate in root explorer to ..
navigate in root explorer to /system/etc
find the hosts file
Long-press and "open in text editor"
repeat steps 5 through 10. (NOTE! "audiogalaxy.com" and "www.audiogalaxy.com" MAY NOT BE THERE. That's ok; they weren't in mine, either. If they aren't in yours, just exit without saving.)
These steps worked for me. If something goes horribly awry, you have your backup to restore, right?"


Dec 11, 2009
Reaction score
I would like an answer to this as well.

When I follow the above instructions, it says the Host file is to large and it doesn't display everything and I can't edit it.

Any help out there?