"No Route Found" solution. One anyway.


New Member
Jan 24, 2011
Reaction score
This is really an answer, not a question, but thought I'd post it since I found almost nothing on the forum about it, and it's a problem that the average user might very well encounter.

The Google Maps Navigation on my droidX has been working well since I got the phone. Ok, it will crash the phone sometimes, but not usually.

I used it today to get to a restaurant and everything was fine. I got home tonight and tried to put in an address I'm going to in a couple of days. I often do this to see what the route and driving time will be and also so the destination will already be on the list and I won't have to enter it when I'm in the car.

So, I enter the destination, which is definitely there on google maps, and up pops a dialog that says "No Route Found" and the only option is "Exit Navigation". I tried the previous destination that worked earlier in the day, and still "No Route Found". GPS was working fine and I could actually see the map under the dialog move a bit indicating that it knew where I was.

What it turned out to be was the data connection. For some reason, the phone had dropped off the wi-fi in my house and couldn't establish an internet connection and (this sucks BTW) did NOT switch automatically to 3G to get data. Every once in a while the phone will do this. The wi-fi "fan" icon was on indicating it thought it had a connection, but for whatever reason, the connection complete to the internet was not working. So, therefore, Navigation couldn't access the route-finding data service at Google.

I have seen this sort of wi-fi purgatory where the phone won't switch to 3G because it thinks it has a wi-fi signal, but it doesn't really.

The solution is merely to go to Settings->Wi-fi and turn off wi-fi. Then access a web page and wait for the 3G icon to appear. Then try entering a route in Nav again. This time, it should work because it has a data connection thru 3G. I found I had to create my home wi-fi network again to get it to pick up, but now everything is back working again.

So, if you get "No Route Found" make sure your connection to the internet is working.

By the way this is a suggestion to Google Maps, if you can't find a route at least TELL ME WHY!! And if you can't get a data connection, try switching to 3G!!