Need help flashing the cdt.bin file in fastboot mode


Nov 22, 2009
Reaction score
The short story is that my phone is stuck in fastboot mode giving me an (invalid CDT/invalid CG Version CG: cdt).

The long story: Managed to get to 5.9.901 (via 5.5.886) using the BionicPathSaver one click method P3Droid posted in mydroidworld, however I lost the 43V3R root I had previously applied. The phone was full of bloatware I decided to repeat the process and reflash 5.5.886 and 43V3R root at that stage and then upgrade to 5.9.901 again.

After repeating the entire process and flashing the 5.5.886 update the phone got stuck in fastboot mode. It was suggested to me that I download an alleged fix to keep root and flash the moto-fastboot executable file included in P3Droid's forum by typing "moto-fastboot flash cdt.bin cdt.901" in a command prompt at the BionicPathSaver directory the executables (and extracted files are located). Unfortunately my command prompt does not understand the "moto-fastboot" command (or the version saying moto-fastboot.exe).

Attempts to restore the bootloader using the R3L3AS3D and 43V3R root or Motorola's RSDLite/FXZ files have failed because of the "cdt.bin" file.

So 4 hours later I'm stuck without a phone. Any ideas?

Thanks a lot!
See if this will run...unzip the file, then run the FixCDT script...
after it flashes the cdt.bin, just disconnect your phone and try rebooting
Last edited:
I have now tested the script I posted and can verify that it does flash the cdt.bin properly and fixes the invalid CDT errors and your Bionic will then boot up properly to stock 5.5.893 OTA... cheers...
Last edited:
Just wanted to let those who experienced the invalid CDT errors that the standalone FixCDT script above works fine, and is a lot easier....just FYI
Thanks!! Added it to my arsenal of utils in case I cave and update to 9.01 and then need to get back on OTA path (5.5.893).
Last edited:
MBK , you are my hero!!!! I was in the same boat as OP (cept I was stuck in fastboot all day) try unsuccessfully to ge t out of fastboot. I was about to throw in the towel and head to my VZ corporate store and suck it up when I decided to check :) the forums before I went to bed. I'm happy to say my phone is back up and running thanks to you. Thanks a ton man:)

Sent from my Xoom
Thanks a lot, but a re-installation of P3Droid's 1-click root and realbbb's root fix allowed me to push the script from the command mode. Another error I had made was that finding the actual directory to run the script from, P3Droid's zipped file resulted in two identically named "BionicPathSaver" folders one inside the other. Wasted about 4 hours to realize that I needed to be in the second directory.

Anyhow, phone booted normally on 5.5.893 with all the bloatware and cannot 43V3R root now, at least not using options 2 or 3. Any ideas? Do I need to revert to stock 5.5..886 and then root? ugh!!!!

I'm glad this was sorted one way or another, so thanks a lot!
Maybe try manually doing a forever root , I believe Droid madder x has s youtube video showing how.

Sent from my DROID BIONIC
can someone please help me, I am in the same situation as the OP however when I attempt to unzip the fixcdt file it says the file is empty !
See if this will run...unzip the file, then run the FixCDT script...
THANKS! Worked awesome! I was in the same boat compiled by a dead battery that I had to charge with stripped wires. I know that's risky but it worked too. Now to see if I can get the phone where I was trying to in the first place. Thanks again :)
See if this will run...unzip the file, then run the FixCDT script...
Holy no more fastboot, Batman. I've spent about 24 hours over the past 4 days trying to fix this. Awesome! Now I can try to update to .902, then ICS. Thanks!