My D2G Display is dead.


New Member
Apr 11, 2011
Reaction score
Hey Everyone-

Okay, so a little background on my D2G:

Running Liberty 2.0.1, flashed it with the d2g rommer (using the correct version). No problems since I did all of this about 3 weeks ago.

Just now when I slid the keyboard out and transitioned to landscape, the entire screen scrambled. I could make out my background and homescreen icons (kind of), I closed the keyboard and it returned to normal. I tried to open it again, and it happened again. This time when I closed the keyboard the jumbled screen remained... jumbled. I removed the battery to do a hard reset and now my D2G won't turn back on. Or at least the display won't turn back on. When I re-insert the battery and hold the power button, the 4 buttons on the bottom light up (and respond to being touched in that they give haptic feedback). I've noticed the screen with slightly light up and then go completely dark in about 2 second cycles.

What to do from here? Rsd/sbf? Any help will be greatly appreciated!

I hooked it up via the USB, and the computer found it. In addition, the LED is blinking like I have notifications. Also when I slide to unlock, it gives me the feedback like I unlocked it. I think the Display just died.

Seeing as I've rooted the phone and installed a custom ROM, I don't think I can just walk into VZW and say "the display is broken", for fear they'll realize I've voided my warranty by rooting and installing that custom ROM. Will VZW not issue me a new phone in this instance if I turn it in the a rooted, custom rom?

Should I SBF? I tried launching RSD Lite and it IS NOT seeing the device? I've used RSD before, with this machine and everything. The thing is I can't even see if I'm getting into the bootloader because my display is completely dead. Very strange. Advice?
1. Pull battery.
2. Insert battery.
3. Hold up arrow while pressing power button to enter bootloader mode. Should only take a few seconds.
4. Plug into computer and see if RSD sees the phone. If not, repeat and hold buttons a bit longer. It will work even if you can't see the display. Just might take a few tries to get into bootloader mode.

Good Luck :)