MotoDroid 1 Previously Rooted But Now Not?

BAD2RAD

New Member
Joined
Jun 22, 2010
Messages
17
Reaction score
0
Location
Virginia
I have a Motorola Droid 1 and it currently has 2.2.1 with FRG83D

Before this last OTA update I had it rooted but since the OTA update, it doesnt seem to be rooted. I have read plenty about how that OTA took away the root access on a lot of phones and have seen where people have the options to try to revert it back to 2.2 FRG22D and reroot and all. Well, even with me having the 2.2.1 with FRG83D, I still have the SuperUser icon, but no Superuser access. Any application that requires permission doesnt get it because I dont get the pop up that supposed to pop up to give the permission it needs to work.

I have tried z4root from the phone (the app) to unroot and reroot but nothing happens. It slows the phone down for a few seconds and thats it and even after powercycling or taking the battery straight out while powered on, it still isnt rooted because any application that needs that permission still isnt asking for it. I have also tried SuperOneClick (or something like that) to unroot and root it and all and still nothing happens after doing all of the above.

If you can help me out with this, it would be great. I have done the research but not coming up with anything. I want to get it rooted so I can get the hotspot thing to work on it. If its possible, I want to unroot it and then reroot it and still have FRG83D 2.2.1 version and be able to do the hotspot and other root-requiring apps. I do understand if it isnt possible and have to run an older version or build. Just seeing if possible and letting you know what I want done. Thanks for your help in advance! It is appreciated!
 
i have a question.

if you are rooted and have an alternate recovery installed (ie clockworkmod) how can an OTA be pushed to your phone?
 
I will try that and see if it works ... thank you

I never said I had an alternate recovery installed on my phone ... i had like clockworkmod installed but i never understood it so i uninstalled it
 
ok then i think that's how you got the OTA. my understanding is that if you have cwm or sprecovery installed, then it will block any ota.
 
Once I get the root issue resolved, I will definitely have one of those installed. Have to find of get some info about it though because I could never get it to work and didnt really understand what I was looking at with it. I do now remember that when the first OTA was sent out after I got my phone that I didnt get it but the second one I did and I dont think I had CWM installed at that time. Thanks for the info!
 
Yeah, you NEVER want to run the stock recovery with a rooted phone if you don't want to lose your root access. The reason the custom recoveries block the OTAs is that you explicitly need to ALLOW update.zip files to install; by default they are blocked. So the phone will download the update, reboot into the custom recovery, and TRY to install the update. But since they are disabled by default, it will throw an error and boot back into the version you were running. The phone will think you have successfully installed it, so it won't bug you any more.

If you re-root using the method I linked, it will also modify a file on the phone so it shouldn't even try to download the update in the first place.
 
Ok I am on the step in RSD Lite where i see my device and have selected the SBF file selected but the start button is greyed out. Did I do something wrong?
 
There's a few tricks in that thread to fix your problem (I'm not about to re-read all 150 pages again, as I do almost everytime I visit it), but did you extract the file so that it has a .sbf extension? Also, I _think_ you can try by putting the .sbrf file somewhere like "c:\" on your computer.

good luck
 
ok then i think that's how you got the OTA. my understanding is that if you have cwm or sprecovery installed, then it will block any ota.

If I may clarify. The main thing that 'blocks' an OTA update is what is contained within the build.prop file on the phone. If certain values there 'seem' to be older than those contained within the OTA, then the OTA will be pushed to the phone. And then to further clarify, CWRecovery _seems_ to go ahead and allow these to be installed to the phone, while SPRecovery will (once you accept and try to install) fail.
 
Last edited:
Here is what I am getting ... i have checked the box and is being run as administrator ... i have put the sbf file in Documents ... Start button is still grayed out ... here is a screenshot of what i am seeing
 
I understand bro, any help you can offer these guys is great, I wrote "busy box, I believe" as to imply my uncertainty on it. As for androot I guess I'm the only one who's got it working.
Sent from my Droid using DroidForums App
 
Back
Top