Milestone 2 keyboard stopped working


New Member
Dec 31, 2010
Reaction score
I recently rooted my phone and edited my keyboard layout files a little(/system/usr/keylayout/). I made up and down "z" and "x" but it didn't work instantly. I backed them up onto my sdcard and have restored them to their original state.

Then, like a day later I noticed the numbers and special characters had been shuffled. I assumed the device automaticly had switched layout from the milestone2 one to the qwerty.kl one. I tried the up and down keys and they produced x's and z's. Then after a while the phone started acting very weird:

  1. The keyboard stopped working.
  2. When spamming keys for a while the phone will go to the homescreen and sometimes reboot.
  3. The menu, home, back keys all do the same thing. It is sometimes something of a combination of back and home. It fades to black and goes to the starting position of the current application. And sometimes the phone will freeze and reboot.
  4. Whenever I use the on-screen keyboard to erase a character or input a number the phone will perform something of a double back-action.

I have tried to to a factory reset in the privacy menu multiple times with my phone un-rooted.

I have also done a factory reset with the 'x' + power then @-key about 3 times but my problem is still there.

Any help on how to resolve this is appreciated.