HELP: CM7 install aborting

sbenson

Silver Member
Joined
Jan 19, 2011
Messages
2,369
Reaction score
61
Location
Virginia/DC Metro Area
I've posted this over in the CM forums but no one can figure this out. I am currently running CM7 (winner's build #28) along with prime's deprimed kernel #13.

Now on to the problem: I downloaded winner's CM7 RC3 and put it on my sd card. I went into RZ recovery and made a backup, then wiped EVERYTHING. I proceeded to install an update like I have done a hundred times before and got the following message within rz recovery:

Opening update package...
E: Can't open /sdcard/Roms/update-cm-7.0.0-RC3-Droid-winner00-signed.zip
(bad)
Installation aborted

I tried multiple times with no luck. Re-downloaded the file multiple times but no luck still. I even tried earlier versions. I then flashed to clockwork recovery (thinking rz was broken) and have the exact same problem.

The strange thing is that I can install gapps as well as kernels, but just not roms? I have about 2 gigs free on my sd card so that shouldn't be the issue.

EDIT: I am unable to install new versions of kernels. I was able to install the one that was on my sd card. I downloaded a new kernel and tried to install it and got the ol' abort message...

Luckily I was able to flash back to my backup, but this is still frustrating since I would like to keep up with the CM updates. It seems as though my recovery is broken somehow. I've never had trouble before, so this is all new to me - I'm pretty much at a loss right now.

Does anyone have a suggestion for me? Thanks in advance, I appreciate any help!
 
Last edited:
I have had similar problems in the past. (I did a ton of things so I am not sure which one fixed the problem but everything works now) I flashed "clockwork version 2.5.0.1 SBF by raidzero" then from CWR I flashed an older version of recovery because the latest would not flash for some reason, then after I flashed the older version I was able to flash the latest version of CWR. I rebooted and then was able to flash Roms again. I then flashed back to raidzero and have not had trouble since. I am not positive if the above was the exact sequence but it is what I remember.
 
All is well, I got it figured out. Turns out after all, that all of the files I was downloading were somehow being corrupted. Maybe my work computer was messing something up somehow- I don't really know.

Anyway, I ended up downloading all of the files directly from my phone when I got home last night and they worked flawlessly! (I couldn't do this earlier because of poor 3g service- this would have saved me a lot of time!)

I wondered what was going on because I could install old existing roms and kernels that I had downloaded a week before, but nothing that I downloaded yesterday would work? Very strange since I've downloaded all of my files from my work computer. I'll have to keep an eye on this. Anyway, now I know what's going on if this happens again.

Thanks again for all the suggestions, I really appreciate the help.
 
Back
Top