GPS suddenly doesn't work


New Member
Feb 12, 2010
Reaction score
Yesterday my GPS stopped working. Now whenever I try navigation it just says "searching for GPS".
In maps, I only get the "cell tower" circle.
And even in the GPS Status app I get 0.00000 for my lat and long.

The "GPS is on" icon comes up in my task bar, but even after having a clear view of the sky for a literal hour it's still "searching for GPS".

I tried turning the gps off and on again and rebooting the phone. No good. I hope I don't have to default it.
Anyone else?

(Las Vegas Nevada. Got 2.1-update1 and system updater says I'm up to date)
You said "even after having a clear view of the sky for a literal hour." Were you stationary during this time? If not, I'd reboot and leave it under open sky while stationary.
No, I was not stationary at the time, I had it up on the dash of my car while I drove home.

I pulled the battery last night (getting my bodyglove super-case off is a biatch) and that seems to have fixed it for now.
Still makes me wonder what the issue was though.
Same the OP..

GPS had been working fine.. Then Tried to navigate, only got searching for GPS, tried battery pull, tried wifi off and on, and tried rebooting.

Stationary and moving wouldn't work, finally while going to a garage sale it, I got the arrow and it started following me..

Using GPS Status and GPS test, I would only get 1-2 satellites (with open sky) and they would be grey..

Had this happen before also.. Donno what causes it.
Mine has suddenly started doing this, about three weeks ago (the time of the former posts). It used to find the GPS from anywhere, within about 10 seconds of going into maps... now it can sit for 30 minutes under a clear sky and find nothing. What's changed??? Annoying!
Mine has been doing this for the last month as well - it will take a few minutes (sometimes quite a bit more) to get a signal - I'm wondering if this is an issue with my particular unit, an issue with the satellites, or an issue with Maps (or some combination). Really frustrating though.....
Searching for GPS

I am having the same issue all of a sudden. Pulled the battery and even did a factory reset. My wife has no problems with her Droid even when we are in the same location. Because it does work periodically, I am less inclined to believe it is a hardware issue. Thoughts?
Not using a Moto Droid but...

I am having this same issue. I have an LG Ally and getting the same "Searching..." message.

Not sure where to turn for this one.


I had the same problem with my Motorola Droid yesterday.

I called Verizon support, and they suggested that I pull the battery out while the phone was on. After waiting about a minute, I replaced the battery and rebooted the phone. They then suggested to us the *228 over the air programming and option 1 (on Verizon) to update the phone.

After the over the air update was complete, the GPS started up and was very quickly able to lock my position. All my settings and apps were retained and the phone is working great now. The support person recommended that I do this on a regular basis to clear out the phone.

I hope that this helps!
gps issue

great forum! droid is my first smart phone. when it is responsive i love it. when it lags i want to return it. i went a week where my internet searches took forever. i did a hard reset and it's better. my big issue is with my google maps 75% of the time can not determine my location. when it does work 25% of the time my location comes up in the east river. when this happens and i use google places i get listings for manhatten. i live in brooklyn. i have talked to 2 tech reps at verizon and both gave the same scripted response- this is not a verizon/motorola issue but instead an issue w the app. did my own "research" with a friend at my place friday with his iphone 3gs and another at a bar in brooklyn w his 3g. both acguired gps instantly while mine lagged.

i also disconnected advanced task killer after reading it was not needed and may effect gps. do i need to return my x for a new one? i want to like this phone. when it's on it's game it's blazing fast. please help! i do not want to be forced to get another phone.

also when i tried to search for a gps thread i get this response- The following words are either very common, too long, or too short and were not included in your search
This has happened twice to me. Each time I immediately recovered by clearing the Cache Memory.