Droid Raxr Maxx either stuck in bootloop or random native app crash soon thereafter


New Member
Nov 11, 2012
Reaction score
Hi. New member. Like nateo33 earlier, I've got a Verizon Droid Razr Maxx mostly stuck in a bootloop.

tl;dr - I've only used Motorola XT912 ROM frimware via Matt's software. Used to work perfect, apps crashing increased over months, app now crash (especially Maps) every 30 minutes recently. Re-flashed today and made it worse -- not accessing GPS/SD devices seems to not crash as often. What stupid thing am I overlooking?

Long, drawn out, sad story version: (Get out your Kleenex!)

My Verizon Raxr Maxx XT912 originally came with Gingerbread (I think) and then after a few months got the ICS OTA update. After a bit, I installed Matt's Droid RAZR Utility 1.80 manually upgraded to 1.81 with a slightly tweaked radio file I rooted it, installed safestrap, played around slightly with a duplicate ROM update, then deinstalled it while inactive.

Later on I rooted the phone and installed a clock NTP daemon and a hosts IP blocker. This worked fine. I even installed ROM Toolbox Pro and disabled some annoying apps in the menu system as well and disabled the autostart functions of some apps. (If I want you up, I'll tell you.) All was fine, I could listen to TuneIn Radio Pro via BlueTooth, have Google Nav telling me where to go, have tTorrent Pro fetching a file at 10MB/sec, have Lux minimize my screen usage, have Fox19 storm tracker monitoring the local weather, and even have Wigle on doing warscanning, all at the same time. Oh, and real-time voice transcription into Handcent as well. All in a small device that I could hold in my hand. That ran on a battery. For hours!

I have a list of the apps (heck, I have the APK files so i can even get back there!). But I kept on adding things - gReader DropBox w/camera upload, and others. I was trying to watch for instability, then back out any recent app to catch the culprits.

That mostly worked, but on a recent trip a few weekends ago, my phone would crash about every 30 minutes running Nav and Audiblle.com via BlueTooth. My friend had an iPhone, so annoying AND embarrassing. Got better once I single-threaded them on the trip.

A week later, even single-threading apps is crashing. ANY app, not any particular one or the foreground app.. So I started disabling the background tasks starting with gReader. Touching the 1.3G directory for Asphalt caused an immediate reboot as well as getting bogged down in Verizon Antivirus (aka McAfee), so I was hopeful there as i deleted it. BZZZT, nope. So off went McAfee, dropbox, weather, SpringPad, alarm clocks, androidlost, and everything else. Crashing got slightly better, and then worse. I finally got fed up a day ago and used Matt's 1.82 utility and installed OTA/6.16.211 *DOWNGRADE, KERNEL WAS 214)

Big difference! Now instead of every 30 minutes it's randomly crashing every 3. Read about deleting the cache volume which sounded great, did that. Again and again. And used 1.80 and flashed multiple times or used 1.82. I considered GB but read that ICS forced a bootloadr version upgrade so I couldn't drop way back and let the OTA process run.

I even tried the Blur_Version.6.12.181.XT912.Verizon.en.US.zip file and forcing it in from the SD card -- that worked but failed with 5 radio ?mismatch? extraction errors at the end. (I read here too that upgrading the radio software caused a "you can't go home again" issue like GB/ICS.

Fine, but the radio seems to work -- I get (when it stays up that long) a 4G signal and can even browse the web (hurriedly.) The Map apps seems to crash within seconds of start, making me wonder about the GPS, which I've disallowed access. Touching the SD card seems fragile as well although the bootloader utilities don't seem to have any trouble. I even managed a few Google Play manual updates, and 4/5 worked, while the last one popped up with invalid signature/invalid format, I forget.

I'm having random daemon app crashes (Sorry, Maps / Google Background Authentication Handler / Storage / pick it) has crashed -- OK). Sometimes it'll give me the foreground "Wait / Report / OK" crash notification.

Right now, it crashes at the diamond logo screen, or it'll crash a random app during startup; it'll crash Settings if I jump over to increase screen timeout. It'll crash Gmail, it'll crash play. Sometimes the app itself just "leaves" -- no crash notification but suddenly I'm not running it anymore.

Offhand I'd think it's a hardware problem or bad flash / ROM problem. I've checked the MD5SUMs of the Windows source ZIPs, they match. I've had stuff running in Windows during a flash upgrade, or not. I've issued the normal or alternate full system reset to clean out /data and /cache. One time in desperation I drooped back to Matt's v1.7 software with "Unbrick ICS 6.16.211" and got VERY upset boot errors. (version check downgrade warning, I think.)

So, I've got the phone asleep and charging right now at 80%. I've got the Motorola ADB drivers loaded on Win7 x64,I can enter fast boot or recovery, I can do a full reset of data/cache, install firmware with fastboot or flash it from the SD card. I've gotten so used to the "Dead Android" screen I'm beginning to think that it *IS* part of the boot-up process.

I've mostly stopped using the external SD card and the GPS, at the same time the apps don't seem to be dying as often. Seemingly only when I use the device. That's an improvment, it used to crash every 30sec-2min without me doing anything.

Any hints??? Have I actually physically broken my droid (I've flashed multiple times but normal flash chips handle thousands of writes before failure, not just tens), is there yet ANOTHER hidden cache somewhere, do I have bad ROM images to start with, do I somehow have Kinky Kables, or are my bits just all upside down?

Thanks for any help / assistance / jokes you can think of. This is really bothering me since (A) I don't have a phone anymore and (B) I can't seem to FIX the stupid thing.