A2sd

i need you help too!Can you sent me a pm?Thanks!

+1 to this! I am not the one to bump a thread or even post but I have been having fits trying to get my /dev/block/mmcblk0p2 to mount to /sd-ext! I have searched and searched and messed up my rom many times trying to use "hacky" scripts and system file edits. The crazy thing is in root explorer /sd-ext shows up but when I open the folder it does not show free/used space. Also when I, "/mount -o rw /dev/block/mmcblk0p2 /sd-ext" from phone terminal or adb shell it returns the following; mount: mounting /dev/block/mmcblk0p2 on /sd-ext failed: Invalid argument. Ran a logcat because someone said this error is due to the fact the file that is trying to be created already exists in /mnt/secure/asec folder. Logcat did not return anything pointing to this. To be safe I deleted all files contained in that folder, but this also produced the same error when attempting to mount /sd-ext.

Sent you a pm, I can help you get it to work as I've done for about 8 people now.

i need your help too!Can you sent me a pm?Thanks!
 
I am having a similar issue:

# /system/bin/a2sd diskspace
/system/bin/a2sd diskspace
[ ] Apps2SD is launching...
__ _____
| \ |
| | |
|__/ | Darktremor Apps2SD 2.7.5.2-1 (2011-01-02)

[ ] GetProp Command = /system/bin/toolbox getprop
[ ] SetProp Command = /system/bin/toolbox setprop
[ ] Mount Point = /system/sd
[ ] Starting Darktremor Apps2SD Version 2.7.5.2-1
[ ] Launching Apps2SD Start Program with diskspace
[ ] Starting Darktremor Apps2SD in diskspace mode
[ ] Displaying Disk Space statistics on SD card
Filesystem Size Used Available Use% Mounted on
df: /dev/block/mmcblk0p2: can't find mount point
[ ] Setting File System Ready property to 1.
#

Having trouble mounting... Can you message me as well ZeroBarrier? I am running a rooted LG Vortex (Froyo 2.2)... Thanks.
 
Update:

# /system/bin/a2sd check
/system/bin/a2sd check
[ ] Apps2SD is launching...
__ _____
| \ |
| | |
|__/ | Darktremor Apps2SD 2.7.5.2-1 (2011-01-02)

[ ] GetProp Command = /system/bin/toolbox getprop
[ ] SetProp Command = /system/bin/toolbox setprop
[ ] Mount Point = /system/sd
[ ] Starting Apps2SD Check Program.
[ ] Checking for ext partition
[X] Ext partition found, but not mounted.
Your rom may not be setup to run Apps2SD.
Check with your rom developer if the boot image
is programmed to run Apps2SD.

Your partition may be using an EXT4 partition,
but your rom may not support EXT4. Repartition
your SD card to use EXT2 or EXT3.

#

Does this mean that my ROM does not support EXT3? That is what I currently is...
 
Update:

# /system/bin/a2sd check
/system/bin/a2sd check
[ ] Apps2SD is launching...
__ _____
| \ |
| | |
|__/ | Darktremor Apps2SD 2.7.5.2-1 (2011-01-02)

[ ] GetProp Command = /system/bin/toolbox getprop
[ ] SetProp Command = /system/bin/toolbox setprop
[ ] Mount Point = /system/sd
[ ] Starting Apps2SD Check Program.
[ ] Checking for ext partition
[X] Ext partition found, but not mounted.
Your rom may not be setup to run Apps2SD.
Check with your rom developer if the boot image
is programmed to run Apps2SD.

Your partition may be using an EXT4 partition,
but your rom may not support EXT4. Repartition
your SD card to use EXT2 or EXT3.

#

Does this mean that my ROM does not support EXT3? That is what I currently is...

yeah ... you are going to need e2fsck module and something else as drivers for ext3 and 4 are not in the base rom. When I was using a2sd+ i had to patch the rom zip with the necessary files to make it work. Using a kernel like slayher's which is ext3 and ext4 compatible isn't enough. If i remember correctly.
 
i can successfully use darktremor's a2sd script after installing slayher's 1.6 kernels, but that's the only kernel i've had any success with. no luck at all with p3droid's kernels with the EXT 2/3/4 module loaded.

i've been using MIUI for about a week now, and this is the only thing keeping me from endorsing it to my other friends with rooted droids. with slayher's kernel i get a lot of wait/fc messages, and general UI stutters. I can't try any other kernels because even the stock wont work with a2sd+.

An a2sd how-to should be a sticky in the MIUI forum, and someone who knows how to do it should provide solutions if possible
 
There is a known ghosting of apps on SD card. I have some days with no reboots needed and today about 8 reboots before my apps showed back up. I get alot of. App not installed on your system. Reboot a bunch then a minute or two after reboot they work.

Sent from my Droid using DroidForums App
 
Back
Top