WIFI won't connect unless screen is on

Discussion in 'LG G2' started by bigzdog, Oct 21, 2015.

  1. bigzdog

    bigzdog New Member

    Joined:
    Sep 4, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have a problem with my LG G2 D800 where it will not connect to wifi unless the screen is on.

    Example: I arrive at home with phone, get on PC, log onto my router and monitor wireless clients. Phone screen still off. No phone on wifi. An hour later there is still no phone on wifi. I then turn on phone screen, I can see no wifi icon in top bar. After a second, wifi icon shows and connects and router shows the client.

    During this time I am getting email notifications so it would still be using mobile data.

    Tested with CM12.1 several different nightlies. Also with SlimSaber several versions and all perform the same.

    I can very reliably cause this by connecting my phone to wifi, start ping to phone ip, then rebooting router. With these roms it will never connect to wifi without turning screen on. With CloudyG2 3.3 rom it will reconnect after a minute of router coming back up. Also my old Atrix HD and Asus TF201 connect quickly also.

    I have taken it back to stock with Supersport's method [FIRMWARE] Flash KitKat the EASY Way!!!! or Go back to JellyBean. I then used Ioroot and AutoRec

    I then tested with a full wipe of everything except internal storage and clean install of these roms. Kept all default settings and did NOT sign into Google, so no apps were restored/downloaded. Nothing running except what comes with the ROM and still have this issue.

    I captured a logcat and below is the timeline.

    Phone connected to wifi then screen turned off. Start ping

    6:11 pm rebooted router - pings drop
    6:12 pm router back online and other wireless devices connected
    6:18 pm still no response from phone
    6:23 pm turn screen on - see wifi connect - ping starts responding

    Logcat
    --------- beginning of system [ 03-13 19:05:21.155 235: 235 I/Vold... - 4fc50273
     
  2. Mustang02

    Mustang02 Diamond Member

    Joined:
    Aug 8, 2010
    Messages:
    7,625
    Likes Received:
    5,115
    Trophy Points:
    1,563
    Location:
    Ohio
    Ratings:
    +6,073
    Current Phone Model:
    Nexus 6P/5X
    Go into the WIFI Advanced settings. Check to make sure the Wifi isn't set to turn off when the phone sleeps.

    2015-10-21 13.54.05.png
     
    • Like Like x 1
    • Agree Agree x 1
  3. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,478
    Likes Received:
    7,056
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,398
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Seems simple, but did you double check your wifi settings on your phone? In advanced settings under wifi, there's an option that's something like "Keep Wi-Fi on during sleep". Make sure that's set to Always. It could be that the phone is disabling wifi when it enters sleep state.

    EDIT: Ninja'd by @Mustang02
     
    • Like Like x 1
  4. bigzdog

    bigzdog New Member

    Joined:
    Sep 4, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Yes it is set to always which is the default on all roms I have tested. The WIFI has no problems staying connected with the screen off, as long as I stay in range it will stay connected.

    It is only when not connected and the screen off, it will never connect until screen is turned on. Like when I come home it will not connect to wifi until the screen is turned on. Even several hours after I got home.
     
  5. bigzdog

    bigzdog New Member

    Joined:
    Sep 4, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I did find this in Nexus forum so it looks like it may be a global Google issue. [Q] Wifi issue ! (Lollipop 5.1)