USB issue and other problems

Discussion in 'Droid RAZR Support' started by Alextroy81, Feb 5, 2014.

  1. Alextroy81
    Offline

    Alextroy81 New Member

    Joined:
    Feb 5, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi friends.

    I´ve many problems in my Razr Maxx and I think they are related.

    I searched a lot of information and I have asked very learned people, but so far nobody has been able to help me.This forum is my last chance.

    Firstly one day I erased the CID of the phone without having made a previous backup, therefore I lost him irremediably (me bad). This by itself is not supposed biggest problem that I must to boot the phone in BPHW Diag & Boot AP mode.

    To correct this I install Safestrap and then I install a custom ROM CM11 in another partition. In this way the phone worked perfectly.

    Suddenly one day phone was turned off and not turned on again , then I had to re-flash a stock ROM and then rooted it again to install Safestrap.

    Here is when my problems really start.
    I boot the phone in FlashBoot mode and install the stock ROM without problem.
    Then I boot the ROM (in BPHW Diag & Boot AP mode) and when I am going to connect the phone to PC by USB to root , but the PC does not detect that the phone is connected .
    Another symptom I see is that the phone is not charging the battery despite being connected to the PC. Then I connect the phone to the wall charger and I notice phone don´t charge neither.

    Because this, I´m not able to root the phone. The all rooting methods I know implies USB conection with PC.

    Before continuing I want to clarify that I have already made all the more obvious tries:

    I tried on 3 different pc. In which I did not have any problems before.
    I tried with 3 different USB cables, which I used before with no problem.
    I've tried different chargers.
    I tried 5 different stock rom I had previously always worked well, among them that of Rogers.
    And of course I always did the relevant wipes.

    Retaking the thread, I have to say that Another issue that I have with the phone is that it does not work the 3g data line. This only occurs whit the stock ROM, because when I use CM11 rom then 3g is working. And this closes the circle of problems that I have:

    Resuming, I can´t use 3g because I can´t install CM11, and I can´t install CM11 because I can´t install Safestrap because I can´t root the phone because Pc don´t detect it when I connect the phone with USB...

    The only way I have to charge the phone is booting in normal mode.
    Remeber that if I don´t boot phone in BPHW Diag & Boot AP mode then it don´t works.

    When I boot in normal mode first Motorola logo appears and then the screen goes completely black, but if I look closely I notice that if the phone is on.

    When the phone is in this state I can connect it to the mains and then the battery is charging. I know this because if I leave it for several hours and when I turn the phone using PHW Diag & Boot AP mode I can see that battery is at 100% capacity.

    Another interesting thing is that when the phone is in this state, I connect it to PC and then it is recognized, but this does not allow me rooting the phone because Android not is on.

    This invite me to thing that it isn´t a hardware mistake.

    If I do the necesary actions to boot Android, then Pc don´t detect again.

    It should be mentioned that when I connect the phone via USB, the PC actually detects something, but then it tries to install some drivers that I don´t not know, but finally fails.

    The mentioned drivers are this:

    DIAG INTERFACE
    MODEM INTERFACE
    MUX INTERFACE
    NMEA INTERFACE
    TCMD INTERFACE

    I hope someone can help me understand what happens.

    If I could connect the phone to PC then I could solve many problems.

    I think I have not forgotten to mention anything.
    Please excuse my bad English.
    I hope I have explained in an understandable way, but it's hard to explain it in my native language. Explain this in English is a challenge for me.

    Best regards.
Search tags for this page

external keyboard android not detected