1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Problems with the Google Browser

Discussion in 'Android Tech Support' started by boatman2220, Dec 21, 2009.

  1. boatman2220
    Offline

    boatman2220 New Member

    Joined:
    Dec 6, 2009
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    0
    I noticed when I open the Browser it's in Spanish. Nothing wrong with that IF that's what you want. I changed the settings and hit SAVE. Same thing, I restarted the phone, same thing. I got the bright idea that maybe cookies weren't enabled. Took a little while to find the settings. ( Open the Browser click the menu then settings ,then more. ) Still no good, went into manage apps, clicked filter. Then went into settings, cleared cache and data. Had to relog into Google, and everywhere else. Still in Spanish. Cookies are enabled, settings are set, and cache cleaned, restarted, and I'm out of ideas now. Oh Yeah, went to Google help and searched, no luck. (That place is a joke )
  2. boatman2220
    Offline

    boatman2220 New Member

    Joined:
    Dec 6, 2009
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    0
    Any suggestions?
  3. 640k
    Offline

    640k New Member

    Joined:
    Nov 4, 2009
    Messages:
    2,123
    Likes Received:
    0
    Trophy Points:
    0
    home - menu - settings - langurage and keyboard - select locale - english
  4. boatman2220
    Offline

    boatman2220 New Member

    Joined:
    Dec 6, 2009
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the suggestion. But still no luck.
  5. 640k
    Offline

    640k New Member

    Joined:
    Nov 4, 2009
    Messages:
    2,123
    Likes Received:
    0
    Trophy Points:
    0
    browser - settings - reset to default?
  6. captainblk
    Offline

    captainblk New Member

    Joined:
    May 11, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I have found that mine does this only in Wi-Fi mode. I have been looking for a solution. When I switch off Wi-Fi, I need to clear the browser cach to make english the default google page. I need to try this on another wifi networ to see if it is something to do with the DNS on my internet connection.
  7. aminaked
    Offline

    aminaked New Member

    Joined:
    Jan 10, 2010
    Messages:
    2,186
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California, USA
    Dolphin hd is a great browser.
Search tags for this page

google browser is in spanish