Problem with Google Maps

Discussion in 'HTC Droid Eris' started by schiefee, Apr 19, 2010.

  1. schiefee
    Offline

    schiefee New Member

    Joined:
    Apr 19, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I just got my new Eris but either the GPS or my Google Maps app is crap. It is totally inaccurate. When I try to get it to point out my location, it puts me across town. That doesn't do me a lot of good if I need directions from my current location. I took it back to Verizon and they told me it was a problem with the app and I would have to wait til it was upgraded. They said it was a common problem, but after a lot of searching the internet, I can't seem to find anyone else talking about it.

    Has anyone else heard of this and does anyone know how to fix it?

    Thanks!
  2. ErisDroid?
    Offline

    ErisDroid? New Member

    Joined:
    Apr 15, 2010
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    0
    Is your GPS on? Is location turned on? Are you sure? Do you see the GPS icon in the notifications bar?

    If not turn it on, here's how:

    Location & GPS; Menu>Location>Check the two boxes>Location settings>Location on. --Also-- Menu>Privacy>Use my location.

    That should work.
  3. schiefee
    Offline

    schiefee New Member

    Joined:
    Apr 19, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Shoot, now I feel stupid :p

    Ok, the GPS is on now, but I can't find the privacy settings for location. I'm still not getting an accurate reading.

    Menu>Settings>?
    Last edited: Apr 19, 2010
  4. droidaphonix
    Offline

    droidaphonix New Member

    Joined:
    Apr 20, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Some things to check out:

    - From Home screen: Menu, Settings, Location
    - Make sure that the "Use GPS Satellites" box is checked.
    - Click on Location Setting and make sure that "Location On" is selected.
    - In Google Maps: Menu, then click on My Location.
    The map should move and the blinking dot/arrow should be centered in the screen and mapped to your location. While you're actively using Google Maps, the GPS satellite icon should also be visible in the notification bar at the top. If that all seems to be working, then take a stroll down the street and you'll see the blue arrow moving along with you, etc. Also, some buildings may block the GPS signals, so make sure that isn't a factor. Of course, using the GPS actively will certainly drain your battery more quickly. The same is true to a lesser degree for Wi-Fi and Bluetooth. Most users will turn these off when aren't using them. There are many GPS/WiFi/Bluetooth Widgets available that you can put on your home screens to make it easy to toggle them on/off.

    Let us know how it goes.
  5. zebug
    Offline

    zebug New Member

    Joined:
    Mar 30, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    buildings do mess with your exact location. I work downtown houston and when I pull up google map in amongst all the high rises it usually has me a block or 2 off, but when I get out on the road away from buildings, then it is spot on.

    I drove from houston to Austin this past weekend using google maps and I only took back roads as much as I could and the app worked perfectly for me.
  6. lokiawse654
    Offline

    lokiawse654 New Member

    Joined:
    Jan 10, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    I've been noticing lately that when I put in an address and attempt to use navigation, it takes a bit longer for it to connect to a satellite. However, today it won't connect at all. Constantly says "Searching for GPS". At one point it showed a blue dot tracking across my screen almost as if it was mimicking a satellite orbit. At this moment I've got 3 bars for cell signal, a blinking gps icon and wifi connected but still not connecting. I'm going to stop into Verizon tomorrow but I'm sure they are going to tell me that it's something to do with Google.
  7. fingaz
    Offline

    fingaz New Member

    Joined:
    Mar 16, 2010
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    New Jersey
    I have experienced a similar issue..

    sometimes if I start googlemaps when gps is turned off, It still locates me via cell phone towers, but It is off by like a quarter mile. If i close the gMaps, turn GPS on, and go back into gMaps, my location will still be off.

    What I had to do was to make sure gMaps wasn't running by closing it using a task killing program.. like Advance Task Killer (ATK). Close out gMaps with ATK, then turn GPS on, open gMaps and GPS works almost instantly.

    try that, maybe that will help your situation.
  8. lodom
    Offline

    lodom New Member

    Joined:
    Apr 21, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I got the same thing. I'll try the task killer.

    BTW, is there a way to have gMaps only keep the screen from sleeping without having the screen stay on all the time. (2.1 v2 leak)
Search tags for this page

blinking dot and arrows on google earth

,

how to make google maps quit blinking