My Droid is Eating My Gmail!

Discussion in 'Android Tech Support' started by dkshaer, Jun 17, 2010.

  1. dkshaer
    Offline

    dkshaer New Member

    Joined:
    Apr 11, 2010
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    0
    :icon_evil::icon_evil:

    When I read an email in my gmail program and do nothing to it, just exit gmail, when I go back in later the email is gone. Not in any other folder, just gone. I believe it is deleted from the server too but I have to check on that. I cannot find a setting that looks like it would change this automatic wipe out.

    Any thoughts?
  2. hookbill
    Offline

    hookbill Premium Member Premium Member

    Joined:
    Nov 30, 2009
    Messages:
    19,545
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    N.E. Ohio
    It's not deleted from the server. And it should show up in your all mail tag.
  3. foolydooly
    Offline

    foolydooly New Member

    Joined:
    Jun 17, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    0
    This is called "archiving" isn't it? This can be disabled in GMail setting. (In website)
  4. hookbill
    Offline

    hookbill Premium Member Premium Member

    Joined:
    Nov 30, 2009
    Messages:
    19,545
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    N.E. Ohio
    Let me back up a bit. The mail doesn't disappear off your phone, it just disappears from the notification window. Unless you delete if you go to your gmail icon it's still there.

    If it isn't then I don't know what to tell you. But either way if you don't delete it it's going to be in all mail. And to the best of my knowledge you can't disable this, however I will freely admit I've never gone looking for a way. I use it frequently to store my emails I want to keep.
  5. toddj
    Offline

    toddj New Member

    Joined:
    Jan 22, 2010
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    U.S.
    I agree with hook. It SHOULD be in all mail. Google's whole thing with email is to never have to delete a message. Perhaps there is a syncing issue with your phone and the gmail servers. Mine does similar weird things from time to time.
    I delete the gmail local cache on my phone when it's acting wonky.
  6. dkshaer
    Offline

    dkshaer New Member

    Joined:
    Apr 11, 2010
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    0
    I'm scared to touch the doggone thing till I get home and can see what is on the server (can't access from my office)

    I did look in All Mail and they are not there. A whole lot of other stuff now is, which I'll have to delete one by one, but the new messages from today are not.
  7. hookbill
    Offline

    hookbill Premium Member Premium Member

    Joined:
    Nov 30, 2009
    Messages:
    19,545
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    N.E. Ohio
    Ok, all you have to do is go to www.gmail.com. Put your user name and password in there and you will find all your mail.

    It's not disappearing. No offense but this is just a case of you not understanding how gmail works with the Droid. You're not telling us what exactly you're looking at with your Droid. Are you pressing the gmail icon, or are you looking at the stock email? Or are you just looking at the alerts, because they will go away once acknowledged. And that's what I think is happening.
  8. dkshaer
    Offline

    dkshaer New Member

    Joined:
    Apr 11, 2010
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    0
    It appears that I don't understand how gmail syncs between the droid and the server. I noticed today that messages (or conversations) come and go, depending on the number days I set the sync to.

    I could use a brief tutorial.

    I did find all of the messages on the server last night but still don't get how they disappeared from the droid.
  9. foolydooly
    Offline

    foolydooly New Member

    Joined:
    Jun 17, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    0
    Goto GMail via website -> Settings -> Forwarding and POP/IMAP

    "2. When messages are accessed with POP" change this to something else, like "keep gmail's copy in inbox"

    also, to retrieve all mails back: Archiving mail - Gmail Help