Moto Car Dock for Bionic - Issues Getting Phone Calls to Come Through Car Stereo

Discussion in 'Android Accessories' started by Peasant_Warrior, Jan 24, 2012.

  1. Peasant_Warrior
    Offline

    Peasant_Warrior New Member

    Joined:
    Jan 24, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hi there - I'm having some drama with my new Motorola Car Dock for my Droid Bionic. (Also having drama with the Bionic itself, but that's another story.) I got the whole car dock set up on the dashboard, have the charger plugged in, the USB connection good to go, and have used navigation and listened to radio/music successfully in the car, with the audio coming *from* the phone and *into* my car speakers.

    However - phone calls, incoming ringtones, voicemail -- all revert to the speakers on the phone (via speakerphone). The music or radio will stop playing through the car speakers, but the phone call will not then come through the speakers. I've tried a few different things, but to no avail. Everything was working fine when I didn't have the dock and just plugged the phone directly into the car through the old school tape deck transformer. Now I am sad. I wonder if it's just some default function that I haven't checked or unchecked somewhere...? Seems like it should be a simple fix but this one's not resolving.

    I tried calling Motorola support since I just bought the thing, but got disconnected twice. I usually scan these forums for answers, and since I didn't see anything quite like this, thought I would post.

    Thanks for any help you might be able to offer!!
  2. steeletown
    Offline

    steeletown Member

    Joined:
    Sep 24, 2011
    Messages:
    259
    Likes Received:
    7
    Trophy Points:
    18
    Is your phone speaker coming on? Some time my calls will come through the phone speaker if my phone is not pressed down all the way on the car dock and does not go into dock mode. If the phone speaker is on you have to turn it off for it to come through your car speakers.

    Sent from my DROID BIONIC using DroidForums
  3. summortuus
    Offline

    summortuus New Member

    Joined:
    Oct 11, 2011
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    0
    I had same issue at first. When in the dock and answering or making phonecalls it defaults to the phones speaker phone. Turn off the speaker phone and the phone call will play over the car stereo.

    Sent from my DROID BIONIC using DroidForums
  4. Peasant_Warrior
    Offline

    Peasant_Warrior New Member

    Joined:
    Jan 24, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    I'll check both things tomorrow, sounds like this will fix it. One question - do I to turn the phone's speakerphone off *every time* I dock the phone, or will it remain off unless I manually turn it back on?

    Thanks!!

  5. Peasant_Warrior
    Offline

    Peasant_Warrior New Member

    Joined:
    Jan 24, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Thanks, checking this first thing tomorrow! :)

  6. summortuus
    Offline

    summortuus New Member

    Joined:
    Oct 11, 2011
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    0
    I have to hit the speaker phone button everytime when docked and in call. If someone has a better fix too I'm all ears.

    Sent from my DROID BIONIC using DroidForums
  7. Peasant_Warrior
    Offline

    Peasant_Warrior New Member

    Joined:
    Jan 24, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Sigh...okay, well, certainly better than what was happening a few hours ago. Thanks again.

  8. johnnyzero
    Offline

    johnnyzero New Member

    Joined:
    Jan 31, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I found a workaround for this!

    After much frustration & a lot of searching, I finally came across a very clever workaround for this issue in a Motorola Atrix-related forum. Cheers and many thanks to ACraigL (Andrew) for his original post.

    Here's how to get around it:

    1) Go to Android Marketplace and install an app called "Setting Profiles". The free Lite version will do the job.

    2) Run Setting Profiles on your phone.

    3) Create a new profile that turns off the speakerphone; call it "Speakerphone Off" or whatever. Hint: to create a profile that does this, clear all the checkboxes and all the green stars, then enable the green star for Speakerphone and make sure that checkbox is unchecked.

    4) Create a new Rule with the following two conditions: Docking State=car dock and Active Call. Use Add Tweak to add a 5-second Activation Delay (this is required so the phone doesn't override the Speakerphone Off setting). Finally, choose Add Action, Activate Profile, Speakerphone Off.

    Voila! All incoming and outgoing calls will now play through your car speakers via the Car Dock's audio out.

    Note: If you have trouble on your phone, try tweaking the delay time. The 5 second delay works flawlessly on my Bionic; the original poster said he ended up using 3 seconds for his Atrix.

    I hope this is helpful to other users.

    best,
    JohnB
Search tags for this page
calls not coming thru car speakers on droid razr
,
droid bionic car cradle problem
,
droid bionic car dock sound
,
droid razr m phone through radio car dock
,
how to answer phone calls android dock
,
motorola bionic speakers for car
,

when motorola bionic in car dock speakerphoene does not come