1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Lost all apps on SD card after "installing" hang.

Discussion in 'Droid 2 Tech Issues' started by kdmw, Jun 22, 2011.

  1. kdmw
    Offline

    kdmw New Member

    Joined:
    Jun 22, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    This is a long one...

    I have a Motorola Droid 2 running Froyo. It's not rooted. Twice within a week's time I've had an issue when upgrading/installing apps. The first time it occurred, I was upgrading 3 apps. They downloaded successfully and began installing, but an hour later they were still installing. I tried canceling the install but that seemed to have no effect. I finally ended up powering off the phone. When I powered it back up, none of my apps on my SD card were recognized.

    I did some initial searching on the web and found various hits for hangs during install. None that I reviewed were helpful in the state my phone was in. I decided to power off the phone and try to access the SD card on my laptop. I had no problem reading the card and even copied it to a directory on my laptop. I had a large number of apps on my card (130+) as well as data, and I figured at that point I was going to have to re-install all of the apps. I decided to buy a new SD card, just to make sure the card itself wasn't an issue. I got an 8GB Sandisk, exactly like what was currently in the phone.

    Using the copy of the original SD card I had on my laptop, I copied all of the data onto the new card. When I powered the phone up I checked to see if any of the apps on the new card were recognized, but they weren't. I did notice that if I went into "Menu -> Settings -> Applications -> Manage Applications -> On SD card", that a list of app files did show up. However, after the phone got a chance to read through the files the icon changed to a dark gray generic icon, and the file name itself continued to be displayed instead of the normally displayed "short" name. When I looked at running apps they displayed the actual app's icon and the "short" name. I could select any of the app files on the SD card, but they could not be moved to the phone.

    I had an app that generated a list of all apps installed, so I could use a list taken previously to determine what needed to be re-installed. I then worked over a number of days to get everything back that I had had installed in the first place. I also installed a couple other apps I felt might help me if I had more problems, and at the same time I re-evaluated some of the apps I had had on the SD card, leaving them on the phone instead of moving them to the card.

    I managed to get the phone back in good shape and everything back to normal, or so I thought. Things were fine for about a day, and then I decided to purchase a few apps. The free version of the apps were already installed and I had been happy with them. Two of the apps downloaded fine, then began installing. After 10 minutes they were still installing. This time I tried canceling them and even though it didn't seem to work they eventually did cancel. I checked an app I knew was on the SD card and it was missing. I then went into "Menu -> Settings -> Applications -> Manage Applications -> On SD card", and everything on the SD card was hosed once again, grayed out icons and long file names.

    While I was looking at it I realized there was an app on the phone itself that I wanted to uninstall. I tried to remove it and it never finished uninstalling. One page I had reviewed in my initial search said to try unmounting the SD card, which I did. I was not successful in unmounting the card, it just hung. I'm assuming something running was accessing a file on the card but I'm not sure what it was/is.

    I decided to try something as a result of another comment I had seen. I powered down the phone and took the SD card out to load it on my laptop. I looked at the directory .android_secure, and found I had 132 app files (.asec extension). I made sure I had a backup of those files in case deleting them hosed anything, then I deleted all files in that directory. I put the card back in the phone, powered it up, and successfully uninstalled the app that had failed before. I also verified my data on the card can be read, and I tried installing one of the apps I had on the SD card back to the card and it worked fine. There was plenty of available space on the card, 3+ GB free before I deleted the .asec files.

    It appears that something is being corrupted during the failed update/install, whether it's a pointer or index. I didn't get the exact count of files in .android_secure the first time around, but I know there were 132 the second time the problem occurred. I am familiar with Linux, but am not sure if the Android OS has some kind of limit at 132? I wouldn't have been overly surprised if it was 128, but offhand I can't think of any significance that 132 would have in my experience.

    Has anyone else had something similar happen? If so, is there any way to fix the issue without the pain of having to re-install everything again? I know I have in some eyes a ridiculous number of apps as I tend to collect things I feel might be useful at some point. If there is a known limit I'll have to slash and burn, without question. Any ideas or suggestions?

    Thanks for any help.
Search tags for this page

android app hang data missing

,

android lost all applications

,

android lost installed applications on sd card

,

apps in sd lost

,

lost all apps on sd card at once