Incredible won't power on at all!

Discussion in 'Droid Incredible Tech Support' started by browseabout, Nov 30, 2010.

  1. browseabout

    browseabout New Member

    Joined:
    Jul 19, 2010
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello all. I had my phone rooted with unrevoked3 a while back. I could not get the recent update, or at the time didn't know how without unrooting so I unrooted my phone a few weeks ago and it recieved the update. Everything has been fine until today. I decided to root my phone again and found out the unrevoked method would not work now since the nov. update. I downgraded back down to my original 2.1 and took updates from there and was gonna stop at 2.2 so I could use unrevoked again but then I decided after all that to just let it take updates and not root. Once I got to 2.2 with the new boot animation and droid voice at boot up. I left to go to eat dinner and the phone had a green circle and arrow, I believe that's what the icon looked like, so I assumed it was just doing the final nov. update so I left it there. When I came back about 20-25 min later the screen was black and the charging led was not on cause it had been plugged into the usb port. I tried to turn on the phone and nothing. I tried the battery pull and nothing. I tried the wall charger and plugging it back into the computer. Still nothing. My wife has the same phone and I tried her battery and chargers and still nothing. Anyone have any ideas of other stuff I could try? Other than that I'm off to the verizon store tomorrow to see if they'll replace it since it's only 5 months old.
     
Search tags for this page

droid incredible won't power on

,
htc incredible won't power-on
,
incredible wont turn on
,
verizon incredible won't power on