Can't search in browser

Discussion in 'cvpcs' started by The Physician, Oct 18, 2010.

  1. The Physician
    Offline

    The Physician New Member

    Joined:
    Jul 31, 2010
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    Can't search from the top bar in the browser without it force closing. I've tried clearing the cache/data, deleting cookies, and I did wipe data before installing 1.1.1.

    Any idea what could be causing this?

    I'd love to not have to go to Google.com everytime I want to search.

    It functioned fine on other ROMs, and pre-1.1 sapphire.
  2. jaykae
    Offline

    jaykae New Member

    Joined:
    Jul 13, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I too have this issue, it will work sometimes typically when first using it, but after trying to reopen it it will keep force quiting. It involves more than searches as well. Entering a web address like facebook.com will crash it as well

    Sent from my Droid using Tapatalk
  3. The Physician
    Offline

    The Physician New Member

    Joined:
    Jul 31, 2010
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    Mine just never works, but web addresses work fine.

    I wonder why everyone is experiencing a wide range of different problems on 1.1.1.

    I'm probably going to switch to a more stable ROM in a few days if these problems don't get sorted.
  4. captdroid
    Offline

    captdroid New Member

    Joined:
    Jun 30, 2010
    Messages:
    1,797
    Likes Received:
    17
    Trophy Points:
    0
    Maybe try a different kernel / voltage / speed. No problem here with FC's in browser entering address's or searching. Running Sapphire 1.1.1
  5. Tsusai
    Offline

    Tsusai New Member

    Joined:
    Jul 14, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    If you've removed the system google search (one that came with gapps update) in order to install the version from the market, that issue will occur. Quick test to know is to hit the search button on the phone. If search doesn't come up, you don't have google search as a system app anymore. just trying to search in the browser URL box instead of through a web page will cause the browser to run the search through the system app, which isn't there. The result in my tests is the Force Close.

    SOLUTION!

    (Originally Posted by jntdroid )

    In Terminal (3 lines):
    sysrw
    ln -s /data/app/com.google.android.googlequicksearchbox*.apk /system/app/GoogleQuickSearchBox.apk
    sysro

    And reboot

    This tells the phone the system version is actually linked to the market based one, and the cool thing is, is that you can do market updates with it :)

    Also, If you chose not to install the google apps package, download Google Search from the market, and run the commands
Search tags for this page
android browser app crashes on search bar
,
android browser crash when typing in address bar
,
android browser search bug
,

android browser search not working

,
android can't search from browser
,

android googlequicksearchbox crash

,
cant search android browser
,
googlequicksearchbox crash
,
search in android browser not working