Can't get any GPS satellite locks.

Discussion in 'Droid 4 Tech Support' started by NeoPhoenixTE, Jun 25, 2013.

  1. NeoPhoenixTE

    NeoPhoenixTE Member

    Joined:
    Dec 20, 2010
    Messages:
    256
    Likes Received:
    24
    Trophy Points:
    18
    Location:
    Fort Collins, CO
    Ratings:
    +24
    Okay, first, I've tried searching the forums, but apparently the forum software likes to obscure a rather important term for this issue: "GPS". So, if someone has already posted in here recently about this, then I apologize. Manual searching left me with one dead and unanswered post that got me nowhere, so I'm posting a fresh post in hopes that some knowledgeable folks can take a look.

    Been running stock JB ROM since the soak. Rooted, etc.

    About a couple weeks ago (~6/11), my phone's GPS accuracy started to, well, suck. It became VERY apparent when my buddy threw me an invite to the Google AR game "Ingress" and it required a decent GPS (accuracy within 100 meters). Unfortunately, mine was far from decent it seems. As time went on for the rest of the week, it became apparent that my phone was not locking on to satellites at all, while standing outside in an open parking lot with nothing but sky all around me.

    All three location service providers were running.
    I had granted Google Apps access to my location.
    I had run both GPSTest as well as GPS Status and Toolbox
    - Cleared AGPS data and downloaded fresh data
    - Both apps report no satellite contacts for 45+ minutes

    I sunk so low as to call Verizon customer service. Their Tier 2 guy had to send me to Google's tech support, which led to them giving me a phone number to call, which ended up being Samsung's tech support line, so, no go there.

    I figured there was something buggy in the stock system, so I installed Safestrap for the D4 and flashed LiquidJB to give it a go.

    Despite the new zippy/cleaner ROM, my GPS problems have persisted with the exact same results as the stock system: zero satellite contacts.

    My GPS accuracy is only as good as the wifi networks and cell towers around me. Unfortunately, that's not good enough for Ingress in my neck of the woods.

    The fact that it's been going on for two weeks today tells me it's not a satellite network problem (I'd have heard about other folks losing GPS capability around here, I'm sure).


    The only approach I've not yet taken is a full SBF and taking the SDCard down with it. I've also considered the possibility that my GPS antenna is physically damaged, especially given the gradual degradation I experienced when this problem first became apparent. Running out of approaches here. x.x

    Are there any steps I've missed?
    Are there steps I can take to check for physical damage?
    Is an SBF unavoidable at this point? If that doesn't work, where does that leave me?

    I've been scouring Google for two weeks straight, and found empty and abandoned posts with little to no answers.

    I just wanna play Ingress. Is that too much to ask? :(


    Update: I've now installed the latest stable CyanogenMOD, and still no love from the satellites. I'll try to let it sit there for as long as the battery can hold out to try to get a lock later this evening to see if that would resolve it.

    Also, given the view count and amount of time that has passed since initially posting this topic, the lack of replies is telling me I've found myself in quite the conundrum. :(
     
Search tags for this page

android galaxy gps cannot lock on satellites

,
android gps cannot luck satelite
,

androidcannotlockontosatellite

,
droid 4 cant see satellites
,
droid x2 gps doesn't lock on
,
galaxy s3 cant lock gps
,
gps available but cannot lock to satelite
,
gps can't find satellites
,
ingress wont find gps galaxy s3
,
why cant my phone retrieve satelite