Bluetooth Issues Fixed In Pixel Server Side Update

Discussion in 'Android News' started by DroidModderX, Mar 24, 2017.

  1. DroidModderX

    DroidModderX Super Moderator
    Staff Member Premium Member

    Joined:
    Oct 6, 2011
    Messages:
    5,626
    Likes Received:
    2,102
    Trophy Points:
    478
    Ratings:
    +2,221
    [​IMG]

    If you have been one of the many that have suffered with the bluetooth bug on the Pixel and Pixel XL it looks like Google may have issued a fix via server side update. An early bug in the Pixel was causing failed bluetooth connectivity in cars. A new issue came up later after the release where bluetooth devices would randomly disconnect. These issues reportedly started after the February security patch.

    A Google Team member has reported in the Pixel User Community forum that Google has just put together a fix for the issue. He went on to mention that no downloads or installs will be necessary indicating it was a server side fix. While the issue is claimed to have been fixed some users are still reporting bluetooth problems. The update began rolling out as part of the Google Play Services update March 21. The update may take a few days to hit your device. Has anyone seen a change? Has this issue gone away for you?

    via Google
     
  2. PereDroid

    PereDroid DF News Team Reporter

    Joined:
    Jan 25, 2010
    Messages:
    5,446
    Likes Received:
    3,267
    Trophy Points:
    1,563
    Location:
    Cleveland, Ohio
    Ratings:
    +3,835
    Current Phone Model:
    Moto Turbo 2
    A server side update? What does that even mean? What does BT have to do with a server?
     
    • Agree Agree x 2
  3. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,686
    Likes Received:
    3,548
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,036
    Current Phone Model:
    iPhone 7 Plus JB
    I'm with you Pere.. If it doesn't require a download, how does it get to your phone?
     
    • Agree Agree x 1
  4. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,484
    Likes Received:
    7,064
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,406
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    I read something this morning that claims that it may have had something to do with Google Play Services, or was fixed through Google Play Services.

    I still think it's a very weird claim to say that a BT issue was fixed with a server side anything.

    I was having BT issues in my truck this morning, but I'm fairly confident that my BT receiver is finally giving out on me. Served me well for the cheap price I paid on Amazon for it. Now, to decide if I buy another just like it or attempt to upgrade my setup a little bit...
     
    • Like Like x 1
  5. johnomaz

    johnomaz Silver Member

    Joined:
    Jul 12, 2010
    Messages:
    3,171
    Likes Received:
    629
    Trophy Points:
    178
    Location:
    Central Valley, California
    Ratings:
    +767
    Current Phone Model:
    Google Pixel XL
    I haven't noticed the issue for a couple days now and it was plaguing me since I got the March security update.
     
  6. DesktopDevin

    DesktopDevin Active Member

    Joined:
    Nov 28, 2009
    Messages:
    382
    Likes Received:
    59
    Trophy Points:
    28
    Location:
    Garner, NC
    Ratings:
    +67
    Current Phone Model:
    HTC One M8
    Somebody needs to go back and read the thread after the announcement, this only fixed issues for some people not all.

    The other thing I noticed in the thread is that it is not only the pixel that is having problems... seems to be affecting several devices on nougat.

    I haven't seen any issues here but then again I am not running nougat on anything yet.

    I guess the NSA hasn't perfected their remote cloning technique yet for nougat. :cool:

    [​IMG]
     
    #6 DesktopDevin, Mar 27, 2017
    Last edited: Mar 27, 2017
  7. Mark_V

    Mark_V Member

    Joined:
    Feb 6, 2010
    Messages:
    91
    Likes Received:
    2
    Trophy Points:
    23
    Location:
    OKC
    Ratings:
    +2
    Current Phone Model:
    Moto G4 Plus
    I have a Moto G4 running 6.x and I was having problems with it connecting to my car as well. Just a few days ago it started working 100% of the time. I would think it would been a fix with Google Play Services as well.