USB audio?

The sequence is weird, and cumbersome, but repeatable.

Plug in DAC with host cable.
Change USB configuration FROM Audio Source to something else. Sometimes it seems to automatically jump back to charge only when you select anything.
Change USB configuration back to Audio Source
Unplug host cable and plug it in again. Then it works. But that seems to be the only sequence that does it.

I really hope they streamline this process. There is a lot of audio power in these phones when you can get USB audio out of them.

It seems to be sounding great! I don't have any FLAC files on the new phone yet, but have a micro SD card all ready to go. I'll transfer some tonight. I'm just listening to Spotify right now, but it does sound as good as Spotify every does. I picked up some "Ouchless" hairbands at the store. They don't have the metal clasp on them, so won't scratch the screen. Great for strapping the DAC to the phone to make a conveniently portable set up.
Okay, it's a PITA, but I got it working. In Developer Options (Explanation on how to get into Developer mode above) there's a selection for USB configuration. With my headphone DAC/Amp plugged in with a host cable, "Audio source" was an available option. But it did take a few tries to make it work. But I am glad it is possible at least.

(edit) It does seem you have to do it each time. Still working out the correct sequence of events to get there. Yeah, a pain, but better than nothing. Sure was easier on my Maxx. However, the USB DAC with the headphone amp didn't work on Maxx. So ultimately, I can finally do what I really want to do, but it is a bit of a pain. #FirstWorldProblems
OK, looking at Developer Options I noticed another switch...

Look lower on the list scrolling down to the "Media" subheading and you should see the following.


It appears to default to on, where the "Disable automatic routing to USB audio peripherals" is set to off. Obviously it's a feature that the phone was designed to support.

Sent from my XT1585 using Tapatalk